CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > Software User Forums > OpenFOAM > OpenFOAM Post-Processing

paraFoam command gives an error

Register Blogs Members List Search Today's Posts Mark Forums Read

Reply
 
LinkBack Thread Tools Search this Thread Display Modes
Old   June 14, 2020, 18:01
Default paraFoam command gives an error
  #1
Senior Member
 
Josh McCraney
Join Date: Jun 2018
Posts: 163
Rep Power: 4
joshmccraney is on a distinguished road
Hi all

I am running both OpenFOAM 4.1-extend and 6.0 on Ubuntu 18.04. When I run a case via of6 and execute paraFoam, everything works as normal. However, when I run a case via of4 and execute paraFoam, I get the error

Code:
Cannot use ParaView reader module library (PVFoamReader)
The PV_PLUGIN_PATH environment value is not set

Continuing with builtin reader:  paraFoam -vtk

Created temporary 'damBreakFine.foam'
/home/josh/foam/foam-extend-4.1/bin/paraFoam: 324: /home/josh/foam/foam-extend-4.1/bin/paraFoam: paraview: not found
I downloaded of4 here but did not yet execute section 1.3, since I already have paraFoam downloaded. Do I need to follow these instructions? If so, will they inhibit the of6 paraFoam that currently works?

Thanks so much!
joshmccraney is offline   Reply With Quote

Old   June 15, 2020, 03:57
Default
  #2
Senior Member
 
Mark Olesen
Join Date: Mar 2009
Location: http://olesenm.github.io/
Posts: 928
Rep Power: 26
olesen will become famous soon enougholesen will become famous soon enough
What is wrong with using the regular builtin OpenFOAM reader? Apart from some face/cell sets (which you can convert with foamToVTK) it handles things quite well. You may have to skip the 0/ directory if you have lots of #include, code stream etc, but that is to be expected.
The only place where the additional special-purpose readers might be useful is for diagnosing complicated blockMeshDict.
Otherwise I just use the following:
Code:
alias parafoam='touch log.foam; paraview log.foam'
olesen is offline   Reply With Quote

Old   June 15, 2020, 11:41
Default
  #3
Senior Member
 
Josh McCraney
Join Date: Jun 2018
Posts: 163
Rep Power: 4
joshmccraney is on a distinguished road
Quote:
Originally Posted by olesen View Post
What is wrong with using the regular builtin OpenFOAM reader?
When I execute the suggested paraFoam -vtk , which I assume is what you're referring to, I still get the error

Code:
Created temporary 'damBreak.foam'
/home/josh/foam/foam-extend-4.1/bin/paraFoam: 324: /home/josh/foam/foam-extend-4.1/bin/paraFoam: paraview: not found
Quote:
Originally Posted by olesen View Post
Otherwise I just use the following:
Code:
alias parafoam='touch log.foam; paraview log.foam'
So inputting this at the end of the bashrc will allow paraFoam to work with of4 and of6 in the same manner (after a simulation, simply execute "paraFoam"?).
joshmccraney is offline   Reply With Quote

Old   June 15, 2020, 16:53
Default
  #4
Senior Member
 
Mark Olesen
Join Date: Mar 2009
Location: http://olesenm.github.io/
Posts: 928
Rep Power: 26
olesen will become famous soon enougholesen will become famous soon enough
sudo apt-get install paraview ?
olesen is offline   Reply With Quote

Old   June 16, 2020, 17:34
Default
  #5
Senior Member
 
Josh McCraney
Join Date: Jun 2018
Posts: 163
Rep Power: 4
joshmccraney is on a distinguished road
Quote:
Originally Posted by olesen View Post
sudo apt-get install paraview ?
I have paraview installed (it works with openFoam 6). But it does not work with openFoam 4.

More specifically, at the end of the bashrc file I have
Code:
alias of6='source /opt/openfoam6/etc/bashrc'
alias of4='source $HOME/foam/foam-extend-4.1/etc/bashrc'
When I execute " of4 " the case runs, but executing " paraFoam " gives the the aforementioned errors, and nothing loads. However, if after running I open a new terminal, execute " of6 " and then execute " paraFoam " everything works. I'd like to be able to run paraFoam without having to open a new terminal everytime.
joshmccraney is offline   Reply With Quote

Old   June 16, 2020, 18:31
Default
  #6
Senior Member
 
Mark Olesen
Join Date: Mar 2009
Location: http://olesenm.github.io/
Posts: 928
Rep Power: 26
olesen will become famous soon enougholesen will become famous soon enough
Quote:
Originally Posted by joshmccraney View Post
I have paraview installed (it works with openFoam 6). But it does not work with openFoam 4.

I meant that you can use your system paraview. Eg, on my ubuntu system
Code:
$ which paraview
/usr/bin/paraview
Or download a binary from https://www.paraview.org/download/

Do neither of these work?
olesen is offline   Reply With Quote

Old   June 16, 2020, 22:07
Default
  #7
Senior Member
 
Josh McCraney
Join Date: Jun 2018
Posts: 163
Rep Power: 4
joshmccraney is on a distinguished road
Quote:
Originally Posted by olesen View Post
I meant that you can use your system paraview. Eg, on my ubuntu system
Code:
$ which paraview
/usr/bin/paraview
Or download a binary from https://www.paraview.org/download/

Do neither of these work?
This opens paraview but it does not allow me to load the simulation. Any ideas?
joshmccraney is offline   Reply With Quote

Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
[swak4Foam] installing funkySetFields igo OpenFOAM Community Contributions 1 November 20, 2012 20:16
Ansys Fluent 13.0 UDF compilation problem in Window XP (32 bit) Yogini Fluent UDF and Scheme Programming 7 October 3, 2012 07:24
ParaView for OF-1.6-ext Chrisi1984 OpenFOAM Installation 0 December 31, 2010 06:42
Problem with compile the setParabolicInlet ivanyao OpenFOAM Running, Solving & CFD 6 September 5, 2008 20:50
Compiling problems with hello worldC fw407 OpenFOAM Installation 21 January 6, 2008 17:38


All times are GMT -4. The time now is 07:55.