CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > Software User Forums > OpenFOAM > OpenFOAM Post-Processing

Problems with probes

Register Blogs Members List Search Today's Posts Mark Forums Read

Like Tree1Likes
  • 1 Post By aero_eng

Reply
 
LinkBack Thread Tools Search this Thread Display Modes
Old   October 19, 2020, 17:59
Default Problems with probes
  #1
New Member
 
Fabio Bianchi
Join Date: Oct 2020
Posts: 2
Rep Power: 0
aero_eng is on a distinguished road
Hello everyone,

I'm running a simulation in chtMultiRegionFoam, and I need to know the values of the temperature in some points, so I used the function probe in this way:
probe
{
type probes;
enabled yes;
writeControl timeStep;
writeInterval 1;

fields (T);
probeLocations
(
(-0.0408 0.03735 0.03)
(0.051 0.0897 0.03)
(0.051 -0.015 0.03)
(-0.0408 -0.06735 0.03)
(0.051 -0.1197 0.03)
);

}
but when I run the simulation OpenFoam gives me this error:

--> FOAM Warning :
From function bool Foam::functionObjectList::read()
in file db/functionObjects/functionObjectList/functionObjectList.C at line 871
Caught FatalError
--> FOAM FATAL ERROR:

request for objectRegistry region0 from objectRegistry caso_thermo failed
available objects of type objectRegistry are

2
(
fluid
solid
)


From function const Type& Foam:bjectRegistry::lookupObject(const Foam::word&) const [with Type = Foam:bjectRegistry]
in file /home/fabio/OpenFOAM/OpenFOAM-8/src/OpenFOAM/lnInclude/objectRegistryTemplates.C at line 211.

Am I doing something wrong?
aero_eng is offline   Reply With Quote

Old   October 20, 2020, 04:33
Default
  #2
Senior Member
 
Yann
Join Date: Apr 2012
Location: France
Posts: 173
Rep Power: 12
Yann is on a distinguished road
Hello Fabio,

I never tried it on probes, but usually with chtMultiRegionFoam you have to specify the region in the function definition.

Try adding a "region" parameter:

Code:
    probe
    {
type probes; enabled yes; writeControl timeStep; writeInterval 1; region your_region_name; fields (T); probeLocations ( (-0.0408 0.03735 0.03) (0.051 0.0897 0.03) (0.051 -0.015 0.03) (-0.0408 -0.06735 0.03) (0.051 -0.1197 0.03) );
}

Let me know if it solves your problem!


Yann
Yann is offline   Reply With Quote

Old   October 20, 2020, 16:26
Default
  #3
New Member
 
Fabio Bianchi
Join Date: Oct 2020
Posts: 2
Rep Power: 0
aero_eng is on a distinguished road
Thank you very much now it works!
Yann likes this.
aero_eng is offline   Reply With Quote

Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
[ICEM] Problems with coedge curves and surfaces tommymoose ANSYS Meshing & Geometry 6 Today 12:12
probes chtMultiRegionFoam (OF v7) carl_r OpenFOAM Post-Processing 1 May 1, 2020 00:21
Error in probes functions!!! Jingxue Wang OpenFOAM Running, Solving & CFD 9 November 25, 2017 10:21
[mesh manipulation] Problems with rotational cyclic boundaries TReviol OpenFOAM Meshing & Mesh Conversion 8 July 11, 2014 04:45
problems with probes() function in chtMultiRegionFoam Victor OpenFOAM 0 November 25, 2009 16:08


All times are GMT -4. The time now is 18:14.