CFD Online Discussion Forums

CFD Online Discussion Forums (
-   OpenFOAM Post-Processing (
-   -   ReconstructPar in OpenFOAM15 (

nicasch November 6, 2008 12:03

Dear all, I run a damBreakWit
Dear all,
I run a damBreakWithObstacle tutorial with automatic mesh refinement. I was able to run it in parallel.
During the first run I stopped it after a while and could not reconstruct the case. I obtained the following message:


Create time

Create mesh for time = 0

Time = 0

Reconstructing FV fields

Reconstructing volScalarFields


Reconstructing volVectorFields


No point fields

No lagrangian fields

Time = 0.00815822

cannot open file

file: /home/eberberovic/OpenFOAM/eberberovic-1.5/run/damBreakWithObstacle/processor0/0 .00815822/polyMesh/pointProcAddressing at line 0.

From function regIOobject::readStream(const word&)
in file db/regIOobject/regIOobjectRead.C at line 66.

FOAM exiting

Then I run the case again until the end time. Running was OK. But reconstruction did not work, I obtained the same error as before.

Any idea why this happens?

Thanks and regards.

mattijs November 7, 2008 05:06

Your mesh has changed. So you
Your mesh has changed. So you cannot just reconstruct the fields onto the original mesh (which is what reconstructPar does). Have a search for 'reconstructParMesh' on this forum.

All times are GMT -4. The time now is 02:50.