CFD Online Discussion Forums

CFD Online Discussion Forums (
-   OpenFOAM Pre-Processing (
-   -   printStack error in parallel run of coalChemistryFoam (

Dingens June 3, 2013 12:32

printStack error in parallel run of coalChemistryFoam
2 Attachment(s)

first of all: I'm (relatively) new to OpenFOAM, so I would really appreciate if you had a little patience with me :)
I did choose this subforum because I think my mistake is somewhere in the pre-processing.

Back to the topic - initially some description of the case I'm running:

I'm running Ubuntu 12.10 in a VirtualBox under Windows7. OF should be the up-to-date 2.2.0.

I'm trying to simulate coal combustion in OpenFOAM with the coalChemistryFoam solver. The Mesh is a (quarter of) a burner in tube-shape. I have one primary inlet for air and coal particels and a secondary inlet for air only. There is an outlet at the opposite end. A cellSet (IgnitionCells) near the primary inlet is set to a fixedTemperatureConstraint of 1800K, which should start the combustion reaction.
The mesh was generated in Fluent (i got it from the University assistant who supervises the project). The rest of the case is a modified simplifiedSiwek tutorial case. Parallelisation method is "simple" in this case, but I also tried "scotch" with a similar result. The decomposeParDict is attached.

The case runs without errors in serial (although there are some problems concerning the combustion I will have to adress). It also works in parallel in OpenFOAM 2.1.x. But when I try to run it in parallel under 2.2.0 I get a nasty printStack error I can't get rid of. My mesh is pretty large and it is really annoying to run the case in serial, so i figured out I'd ask you for help ;)

I'll attatch the log of the terminal including the error to this post.

I would be really grateful, if someone could take a look at it and maybe give me a hint how to solve this problem. If any additional information is needed please tell me, i will post it as fast as possible.

Thank you very much for your attention and help!


wyldckat June 16, 2013 12:40

Greetings Dingens and welcome to the forum!

Sorry for the late reply, but I was hoping that someone else would answer you sooner... but I guess everyone if busy with tasks for the end of the middle of the year :)

OK, based on the information you've provided, there are only two suggestions I can think of:
  1. You can run topoSet in parallel, the same way you do for the solvers:

    mpirun -np 4 topoSet -parallel
  2. OpenFOAM 2.2.0 might have some issues in the combustion part that might have already been solved in 2.2.x, as you can inspect in the following online folder:
Beyond this, the only way to help you is if you create a very small example of your case that reproduces the same problem, so that I or anyone else can test with 2.2.x. Because this way, you'll also have a test case that can be used for a bug report, in case this relates to a bug that exists only in 2.2.x.

Best regards,

All times are GMT -4. The time now is 21:29.