CFD Online Discussion Forums

CFD Online Discussion Forums (
-   OpenFOAM Pre-Processing (
-   -   Problem with wmake:Header file not found (

hrushi.397 July 31, 2013 02:35

Problem with wmake:Header file not found
Hi All,

I am a newbie to Openfoam. I made few changes in laplacian foam and wanted to compile it. But while compiling it gave me an error saying header file simpleControl.H was not found. It is not there in dependency list too. What could be the reason for this?

I have left the contents of Make folder unchanged.



Artur July 31, 2013 06:53

Could you provide some more details as to how you went about compiling the new solver? There could be numerous reasons for the dependencies being missing. Have you followed this or something similar:


hrushi.397 July 31, 2013 07:10

Thanks for the reply Artur.

I am solving allen-cahn equation. My openfoam is installed in /opt folder, so I copied laplacianfoam solver from there into my home folder. Then I made the changes to the equation that I wish to solve. There was no .dep file earlier in the folder when I copied it. After changing name of the .C file in 'files' file in Make directory as mentioned in the tutorial, I simply ran wmake. It gives me error saying simpleControl.H not found and I can't see it even in .dep file.

Later I tried including path to simpleControl.H in the options file in Make folder, but it still gave same error.

Does it help or do I have to upload the files? I will be able to upload them a bit later as I am in office right now and not at home.

Artur July 31, 2013 07:17

1 Attachment(s)
I just recompiled laplacian foam to check it and it works fine. Here's what I've done:

1. copy the solver to $HOME/OpenFOAM/artur-2.2.0/applications
2. rename the laplacianFoam.C to mylaplacianFoam.C
3. change the name of the file in make/files to mylaplacianFoam.C
4. change the solver name to mylaplacianFoam in files
5. change the directory to FOAM_USER_APPBIN from FOAM_APPBIN
6. wmake it

find the attached compressed solver. Hope this helps.

Not really sure what you were doing wrong though, perhaps it will be worth posting here for others to look at if you figure it out.

hrushi.397 July 31, 2013 07:29

Thank you Artur. I will surely post the files when I go back home from office.

hrushi.397 July 31, 2013 10:34

Hey, I found the mistake. I had two Openfoam versions installed and I took two files from two different versions... unknowingly... now it is working fine :)

All times are GMT -4. The time now is 04:09.