CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > Software User Forums > OpenFOAM > OpenFOAM Pre-Processing

multiRegionHeaterRadiation - Radiation problems

Register Blogs Members List Search Today's Posts Mark Forums Read

Reply
 
LinkBack Thread Tools Search this Thread Display Modes
Old   August 20, 2018, 07:12
Default multiRegionHeaterRadiation - Radiation problems
  #1
Senior Member
 
Peter Hess
Join Date: Apr 2011
Location: Austria
Posts: 228
Rep Power: 13
peterhess is on a distinguished road
Hello Everybody!

During my learning journey in openFoam I have some questions about calculating the radiation using viewFactor model.

I am using openFoam 6.0. I believe the same is happening in openFoam 5.0 or older versions...

Tutorial multiRegionHeaterRadiation.


Running the tutorial with default setup:

1- Taking a look to qr in topAir after 1800 iterations shows that the emissivity for all the surrounding boundaries (i.e. minY, maxX, minZ, maxZ and maxY) is equal to 1 as defined in 0/topAir/qr. Changing the emissivity for those boundaries to any value in 0/topAir/qr will result the change in 1800.
Anyway, where is an interface (i.e. topAir_to_.*) the emissivity is 0 in 1800 but defined to be 1 in 0/topAir/qr!!!

The question is why?

Changing the value of the emissivity in topAir_to_.* to any value (in 0/topAir/qr) does not affect the results after 1800 iterations also. It has simply no effect on the calculation. Well theoretically it should have in my opinion… Am I right?

2- After generating the viewFactor a file called viewFactorField in 0/topAir/ is generated. All the values inside this file are higher than 1. Well for my poor knowledge the viewFactor between any two patches should never be higher than 1. Am I right? Why is that?

There are more question around the tutorial, but let us consider for now those two observations to make the discussion efficient.

Regards

Peter
peterhess is offline   Reply With Quote

Old   August 22, 2018, 03:59
Default
  #2
Senior Member
 
Peter Hess
Join Date: Apr 2011
Location: Austria
Posts: 228
Rep Power: 13
peterhess is on a distinguished road
Well after some tests I can say that in the radiation there is something strange happening...

Anyway, The first problem I am facing with the tutorial was the 0 emissivity at the mappedWalls boandaries.

This problem could be solved by changing the emissivityMode for all mappedWalls in 0/topAir/qr from solidRadiation (default in the simulation) to lookup!!!

Applying those changes results not just the change in the emmisivity of the mappedWalls in iteration 1800 (default simulation ende) but also delivers different temperature results. I.e. there is an effect.

Am I right? do anybody has someting to comment here

Last edited by peterhess; August 22, 2018 at 07:38.
peterhess is offline   Reply With Quote

Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Monte Carlo Simulation: H-Energy is not convergating & high Incident Radiation volleyHC CFX 5 April 3, 2016 05:41
Problem: radiation / patches FAPSler STAR-CD 0 July 29, 2009 09:42
Radiation bc problems multiplying fields tehache OpenFOAM Running, Solving & CFD 4 February 6, 2007 02:37
Radiation: definitions visatron CFX 7 January 8, 2004 15:25
Some problems with Star CD Micha Siemens 0 August 6, 2003 13:55


All times are GMT -4. The time now is 02:02.