CFD Online Discussion Forums

CFD Online Discussion Forums (
-   OpenFOAM Pre-Processing (
-   -   Problem with running FoamX in a distributed environment (

susana March 28, 2007 05:42

Hi All, I am having a prob
Hi All,
I am having a problem and will be truly grateful if someone can help me.

I have 2 machines A & B, A running Foam on Fedora 6 (32-bit) and B running Foam on SuSE 10 (64 bit). I ran the runFoamXHB script on B (i.e started name service on B) and tried to start FoamX on A to connect to machine B's name service. The FoamX GUI starts (with no host details on it) and I get an error "Default Name service could not be contacted"

I have been reading through a lot of posts and did what was mentioned there but still cannot solve the problem. What I did:

1. copied ns.ref in machine B to machine A (directory../OpenFOam/...Apps/FoamX/)
2. changed the FoamXClient.cfg in both A and B to point Host = B and port = 1234.
3. changed /etc/hosts on both machines to include both own and each other's hostnames
4. no firewall running on both machines.
5. When all the above still did not solve the problem, I changed the port number to 123456...but still have same problem..
6. I ran nsd on both A and B locally and a sample CORBA server and client program on the same machine can see and connect to it.
7. I can telnet, ftp from both machines.

Now I am really stuck and dont know what other options to try....can someone PLEASE HELP.

Thanks a lot,

mattijs March 28, 2007 17:11

Do an iordump/iordecode on tha
Do an iordump/iordecode on that ns.ref. Pick up B's fully resolved name from there and see if you can telnet to the nsd using that:

telnet fully-resolved-name 1234

All times are GMT -4. The time now is 20:46.