CFD Online Discussion Forums

CFD Online Discussion Forums (
-   OpenFOAM Pre-Processing (
-   -   Running FoamX independently by 2 users (

rogn November 6, 2006 08:19

Hello I have a problem with

I have a problem with FoamX. We are 4 different users running OpenFOAM on a cluster headnode with different logon names. We are not able to run FoamX independently. A single user can open FoamX on the headnode, but as soon as another user attempts to open FoamX a mico exception occurs:

uncaught MICO exception: (0, not-completed)

~/OpenFOAM/OpenFOAM-1.3/bin/runFoamXHB: line 127: 23214 Aborted (core dumped) nsd -ORBIIOPAddr $myIOP --ior $FOAMX_CONFIG/ns.ref </dev/null

Can anyone help me to make a workaround, or explain to me, how to set up FoamX, so the different users can work independently in FoamX.

Thank you in advance

Rolf Hansen

mattijs November 7, 2006 04:34

Check what your FOAMX_CONFIG i
Check what your FOAMX_CONFIG is set to. Probably all point to the same central installation so the ns.ref file (which gets written there) gets corrupted.

Just copy the .OpenFOAM-1.3 directory to everyone's home directory. FoamX will detect this and use it instead as its config directory.

rogn November 8, 2006 09:00

Hello Mattijs We all use se
Hello Mattijs

We all use separate installations of OpenFOAM. (Actually my colleague is running OpenFOAM-1.2, while I'm on the 1.3 version), so our $FOAMX_CONFIG is not pointing toward the same place (I checked it just to be sure!!).

Best regards

Rolf Hansen

mattijs November 9, 2006 03:48

Change the port number in $FOA
Change the port number in $FOAMX_CONFIG/FoamXClient.cfg so they don't conflict?

rogn November 13, 2006 05:11

Now it works!!! Thank you v
Now it works!!!

Thank you very much

All times are GMT -4. The time now is 03:13.