CFD Online Discussion Forums

CFD Online Discussion Forums (https://www.cfd-online.com/Forums/)
-   OpenFOAM Pre-Processing (https://www.cfd-online.com/Forums/openfoam-pre-processing/)
-   -   FoamX does not eat numbers (https://www.cfd-online.com/Forums/openfoam-pre-processing/62226-foamx-does-not-eat-numbers.html)

Martin Lorenz (Lorenz) February 16, 2005 06:06

Hello, whenever I would like
 
Hello,
whenever I would like to change any number within FoamX (for example a boundary value), it complains with a FoamXException:
"Number 123.45 not of correct type!"
Even if i don't change a value, but simply move the cursor to the field and press Tab/Enter, I get the same message!

Any hints? I have OpenFoam 1.0.2/Linux and use the Java SDK as downloaded from the OpenFoam site.

Mattijs Janssens (Mattijs) February 16, 2005 06:29

I think this is somewhere on
 
I think this is somewhere on this site and has to do with the language Java expects numbers in (LANG environment setting). You should be able to find it using the search facility.

Mattijs

gfollert March 23, 2005 19:00

i have the same problem... i'm
 
i have the same problem... i'm trying but it's impossible.

atzaru March 23, 2005 19:30

Well i had the same problem He
 
Well i had the same problem Here is how to solve:

you need to edit your .bash file in ~/OpenFOAM/OpenFOAM-1.0/.OpenFOAM-1.0/bashrc

just add at the very begining

export LANG=en_EN

Hope this work

Atzaru

gfollert March 28, 2005 15:33

at least for me it doesn't wor
 
at least for me it doesn't work. I'm running on mandrake 10.1 and OpenFOAM 1.1, and it's impossible to modify any value on the dictionaries.

gfollert March 29, 2005 00:53

well, i have re-installed linu
 
well, i have re-installed linux (and OpenFOAM, obviously), but in english (i've previously installed linux in my "native" language:spanish), and everything seems to be OK...

gfollert April 12, 2005 15:56

i tried in another pc with FC3
 
i tried in another pc with FC3 and it works fine

laika August 31, 2005 12:32

I had the same problem here on
 
I had the same problem here on SuSe9.3 with Dutch language settings. Setting the LANG variable to en_EN prior to starting FoamX solved the problem.

cheers,

Laika,
still orbiting

newbee January 21, 2006 17:06

Thank you it worked for me to.
 
Thank you it worked for me to. Im on a inspiron 1300 laptop using ubuntu 5.10.

newbee January 21, 2006 18:03

Thank you it worked for me to.
 
Thank you it worked for me to. Im on a inspiron 1300 laptop using ubuntu 5.10.


All times are GMT -4. The time now is 05:18.