CFD Online Discussion Forums

CFD Online Discussion Forums (
-   OpenFOAM Pre-Processing (
-   -   RunFoamXHB problem (

crosby December 1, 2005 04:32

Can anybody help me with this?
Can anybody help me with this? I can't get FoamX started because runFoamXHB is unhappy about something. The OS is Fedora Core 4 on AMD64, and I've installed and compiled from source for 64-bit. I suspect that the problem is being caused by some network service that Fedora is blocking, but I haven't been able to find it. Any suggestions? Error message is as given below:

/home/charles/OpenFOAM/OpenFOAM-1.2/bin/runFoamXHB: line 131: 14338 Segmentation fault FoamXHostBrowser -ORBNamingAddr $myIOP
runFoamXHB : cleanup
runFoamXHB: Killing name server nsd(pid 14330).
/home/charles/OpenFOAM/OpenFOAM-1.2/bin/runFoamXHB: line 66: 14330 Killed nsd -ORBIIOPAddr $myIOP --ior $FOAMX_CONFIG/ns.ref </dev/null

mattijs December 1, 2005 05:30

Have you tried changing the po
Have you tried changing the port? In $FOAMX_CONFIG/FoamXClient.cfg

Can run 64bit under Suse10 fine on amd64 so cannot be architecture issue.

crosby December 1, 2005 05:52

Thanks for that piece of advic
Thanks for that piece of advice Mattijs. I tried setting the port explicitly to 1234, but that didn't seem to make any difference. Then I switched the 64-bit flag off and it did work. I think now that I have a mixup of 32-bit and 64-bit libraries and executables (paraFoam wasn't happy either), so now I am trying a wcleanall and rebuild in pure 32-bit mode.

All times are GMT -4. The time now is 04:53.