CFD Online Discussion Forums

CFD Online Discussion Forums (
-   OpenFOAM Pre-Processing (
-   -   IcoTopoFoammixer2D cannot be opened from FoamX (

dmoroian October 15, 2005 14:25

Hello everybody, I come again
Hello everybody,
I come again with a problem which probably is a newbie one. I have started the tutorials described very nice in the manual and they seem to work well.
Because I am interested in sliding mesh capabilities, I tried the mixer2D case, but when I tried to open it with FoamX I got the following error:

Exec : FoamXCaseServer /home/dragos/OpenFOAM/dragos-1.2/run/tutorials/icoTopoFoam mixer2D -open
Date : Oct 15 2005
Time : 20:02:14
Host : bobby
PID : 4619
Root : /home/dragos/OpenFOAM/dragos-1.2/run/tutorials/icoTopoFoam
Case : mixer2D
Nprocs : 1
Caught FoamXError exception in FoamXCaseServer::main(int argc, char **argv) :
FoamXError "getApplication::Invalid application class name 'icoTopoFoam'."
In function "IPropertiesImpl"
in file "IPropertiesImpl.C" at line 910
Finishing FoamXCaseServer::main(int argc, char **argv)

Of course it works excelent from the command line, I already saw the results.
If I try to generate a new case with icoTopoFoam as solver, there is no such option in the list with available solvers.
What can be the problem?

Thank you,

mattijs October 16, 2005 11:56

Some solvers do not have a Foa
Some solvers do not have a FoamX configuration file so I guess that is the case for icoTopoFoam.

dmoroian October 16, 2005 13:47

Hi Mattijs, Tanks for the qui
Hi Mattijs,
Tanks for the quick response! I took a look in the OpenFOAM/OpenFOAM-1.2/applications/solvers/incompressible and I saw a FoamX directory in each solver that appears in the GUI. There is no FoamX in icoTopoFoam so I suppose this is the missing configuration that you mention. But it looks like I have to compile again FoamX, right? Also, what should be included in FoamX configuration directory?

Thank you,

hjasak October 18, 2005 11:12

You dont need to recompile Foa
You dont need to recompile FoamX. For examples of what the setup files look like, try some other applications, e.g. icoFoam.

I use the solver without FoamX - have a look at the manual to see how its done.



All times are GMT -4. The time now is 00:23.