CFD Online Discussion Forums

CFD Online Discussion Forums (https://www.cfd-online.com/Forums/)
-   OpenFOAM Pre-Processing (https://www.cfd-online.com/Forums/openfoam-pre-processing/)
-   -   C8H18 implement into dieselFoam (https://www.cfd-online.com/Forums/openfoam-pre-processing/71042-c8h18-implement-into-dieselfoam.html)

Peter_600 December 13, 2009 15:58

C8H18 implement into dieselFoam
 
Hi!

I have a problem with the implementation of C8H18 into my case.
I 'd like to inject C8H18 into my engine. I am using the same chem.inp therm.dat files as in the dieselFoam tutorial.

I added C8H18 into the chem.inp file and did all necessary changes to the other scripts, like in the tutorial.

I don t succeed to run the case, with that fuel composition.

Why does it work, with a composition of C7H16- C6H14, like in the tutorial ,but not with C7H16 -C8H18.

... this is the message of OpenFOAM


C8H18 not found in table. Valid entries:
820
(
CL3SISICL
A2C2HB*
SIF3NH2
...
...
...
OCHNNHO
S-TRIAZINE
NAO-
)

From function HashTable<T, Key, Hash>::operator[](const Key&) const
in file /home/peter/OpenFOAM/OpenFOAM-1.6/src/OpenFOAM/lnInclude/HashTableI.H at line 128.

FOAM exiting


I appreciate any help!

Peter

kalle December 13, 2009 22:45

Hi Peter!

The problem is likely that C8H18 is not included in your thermo file. You'll need an entry there for each species in your composition. Which reaction mechanism do you use? Sometimes the provider of the mechanism will also provide thermodynamic data. At least they should state which data they used. A bit of googling should help you to find the required data.

Good luck
Kalle

Peter_600 December 14, 2009 11:06

Hi Kalle!

Thx for the quick replay.

In ur opinion, I just need a valid entry of C8H18 in my therm.dat.

I already tried it, but just by stupid replacing of a specie by C8H18 ( of course it doesn t make physicaly sense, but it should work. Or I am wrong?

I tried different kind of settings but nothing worked.

I am using the chem.inp and therm.dat file from the tutorial dieselFoam.
The one equation reaction mechanism with C7H16 and by adding a second liquid (C8H18). Its similar to the the tutorial settings, but instead of using C6H14 as second liquid, I try to use C8H18.


thx in advance

Peter

niklas December 14, 2009 11:50

can you attach the non-working case

Peter_600 December 14, 2009 13:10

Hi Niklas,

I solved my problem by myself. It was a stupid mistake.

I referred all the time to a wrong therm.dat file.
The path in the thermophysicalProperties file for the therm.dat was

CHEMKINThermoFile "~OpenFOAM/thermoData/therm.dat";

I just changed it to

CHEMKINThermoFile "$FOAM_CASE/chemkin/therm.dat";

Where i actually did my changes according to the therm.dat.

Now, I will try to use the real chem.inp file with the corresponding therm.dat.

Thank u anyway for offering ur help.
I appreciate it.

Best regards
Peter

vitvit July 1, 2011 07:16

Implement new liquid
 
Hi,
I searched the web for simple steps for adding new liquid to OF without any luck.
I know all the polynomial coefficients and I have the files ready, I just don't know how to compile them - a stupid problem, I know..
can anyone help me?
a simple example step by step on one of the liquids in OF would be nice.. say rename H2O to WATER and compile it. many thanks!!

user10600 November 4, 2015 06:16

Hi Peter !

What coefficient values did you put into your therm.dat file for the specie C8H18 ?

Thanks in advance!


All times are GMT -4. The time now is 01:39.