CFD Online Discussion Forums

CFD Online Discussion Forums (
-   OpenFOAM Programming & Development (
-   -   Error compiling new drag model (

deep_seak May 14, 2012 10:30

Error compiling new drag model
I am trying to introduce a new drag model in compressibleTwoPhaseEulerFoam solver but on executing the "wmake libso" command i get following error.
"No rule to make target 'dragModels/Mydragmodel/Mydragmodel.dep' , needed by 'Make/linuxGccDPOpt/dependencies' . Stop."

Please help me in this....


kmooney May 14, 2012 18:01

Have you tried running 'wclean' first? Also, what does the 'Make/files' contain?

deep_seak May 15, 2012 09:16

Yes, i have tried running wclean first but of no use. The Make/files within the "interfacialModles" contains the declaration of different heat transfer and drag models which can be used. I have added the declaration for my drag model in it.

wiedangel June 27, 2012 04:55

sometimes you need to check if the *.C file has the same name as you gave your executable in the "file" document.

Good luck

anon_a June 27, 2012 06:41

Sometimes you may also need to use a "make*" command in order to add your model to the tables containing the list of available models (I think these are called the runtime tables or something similar. But I could be very wrong).

For example, I frequently use the dsmcFoam solver. There exist various models for the inflow of molecules. If I want to make a new one, I should not only copy the directory closest to my case but I should add an entry in


so that it is known to the solver. Just check this file to see what I mean.

The easiest way to find what you need to do is to grep for an existing model.
E.g. if there was a "previousModel" you can just go to the main directory and type


grep -r previousModel ./
This should give you an idea of what is missing or what needs to be modified.

EDIT: Cool, I just realised this was a rather old post. Anyway, I hope someone will find it useful.

All times are GMT -4. The time now is 15:08.