CFD Online Discussion Forums

CFD Online Discussion Forums (
-   OpenFOAM Programming & Development (
-   -   using other compilers (

soeren87 November 6, 2009 06:47

using other compilers
I got my answers and this topic can be closed


i am not a good programmer but for some studies i am trying to recompile the icoFoam solver (not really necessary) with an other c++ compiler.
First there were many problems with missing header files, but after putting them (about 2000) into a special folder, the compiler got them.

Now the Header files produce many errors like:

/home/me/include/scalar.H(40): error: pTraits is not a template
/home/me/include/scalar.H(40): error: identifier "Scalar" is undefined
/home/me/include/scalar.H(42): error: "Scalar" is not a type name

the code of scalar.H in that lines is:
class pTraits<Scalar>
Scalar p_

i am wondering that the makefile compiler works with that file and mine produces many errors.
Can you give me a hint how to go on ?
I guess the compiler wants to have an other syntax, but than i would have to change each used header file..:eek:

have you experiences with other compilers ?

aminsamf July 15, 2014 15:56

Hi there,

I have the same problem. Could u plz tell me how u fixed your problem?

Thank u in advance.


soeren87 July 16, 2014 04:52

Sorry Amin,

my post is 5 years old and I dont know my aim of compiling it.

I guess there are two possibilities:

The first is compiling it on windows.
Finally I used blueCFD which is a whole package of compiled windows solvers. It is very good working.

The second possibility is that i wanted to modify the solver in order to get the kernel processing on GPU.
Have a look at

Sorry it is too long time ago :(

David* September 30, 2015 07:51

For future reference:

The error results from the environment variable $WM_SP not being set. Because of that, scalar.H does not define the type scalar.

I encountered this error while trying to compile a C++ file with Intel Compiler using an OpenFOAM header file.

This post told me to use the compiler flag -DWM-DP (double precision) and now it works!

Cheers, David

All times are GMT -4. The time now is 15:50.