CFD Online Discussion Forums

CFD Online Discussion Forums (
-   OpenFOAM Running, Solving & CFD (
-   -   Parallel Problems (

james80 August 16, 2012 06:28

Parallel Problems

Very new to OpenFOAM, managed to get simulations running properly, but now trying to move onto bigger and better things,

very basic but i want to run a simulation across the 4 CPUs in my machine, i have been able to run decomposePar, but then im having trouble actually running the simulation in parallel.

i have been entering:

mpirun -np 4 simpleFoam -case $FOAM_RUN/ConvergingPipe \-parallel > log

but it will not run, getting a variety of error messages, none of which i can make sense of!

any help Appreciated



niklas August 16, 2012 07:11

...and you wont get any help if you dont post the error message

james80 August 16, 2012 08:11

Sorry about that, when i try to run it this time, this is what i entered and what came up,

lobby@lobby-desktop:~/OpenFOAM/lobby-2.0.1/run/James/Basic/pipe/simpleFoam/ConvergingPipe$ mpirun -np 4 simpleFoam -case $FOAM_RUN/James/Basic/pipe/simpleFoam/ConvergingPipe \-parallel > log
[0] Cannot read "/home/lobby/OpenFOAM/lobby-2.1.1/run/James/Basic/pipe/simpleFoam/ConvergingPipe/system/decomposeParDict"
FOAM parallel run exiting
MPI_ABORT was invoked on rank 0 in communicator MPI_COMM_WORLD
with errorcode 1.

NOTE: invoking MPI_ABORT causes Open MPI to kill all MPI processes.
You may or may not see output from other processes, depending on
exactly when Open MPI kills them.
mpirun has exited due to process rank 0 with PID 3327 on
node lobby-desktop exiting without calling "finalize". This may
have caused other processes in the application to be
terminated by signals sent by mpirun (as reported here).

but decomposeParDict is in the system folder under that case??

niklas August 16, 2012 08:38

how were you able to run decomposePar without the decomposeParDict?

james80 August 16, 2012 08:40

decomposeParDict IS in that folder, i ran decomposePar fine, just when i try to start the simulation it won't read it i guess??

niklas August 16, 2012 08:56


so if you go to that case directory and type
mpirun -np 4 simpleFoam -parallel

does that work?

james80 August 16, 2012 09:07

Yesss!! i swapped out the old decomposeParDict for a fresh one from the tutorials and with this seems to be working now, thanks

hawkeye321 October 30, 2012 15:10

Simple 2D parallel heat conduction
2 Attachment(s)
I am running a simple 2D heat condition problem in parallel. The domain is decomposed into 4 equal regions in the horizontal direction. The temperature contour looks like file 4 in attachment. However, when I am running the case on 1 processor the contour looks like file 1. As you see, the temperatures do not seem to be right at the intersection of the domains, solved by different processors. Any idea what is wrong?

All times are GMT -4. The time now is 19:52.