CFD Online Discussion Forums

CFD Online Discussion Forums (
-   OpenFOAM Running, Solving & CFD (
-   -   Error running Propeller Tutorial (

TOM01 February 9, 2013 10:44

Error running Propeller Tutorial
I'm rather new to Openfoam and trying to run the propellor tutorial.
An error occurs while running the Allrun script:

in log.createBaffles


Converting faces on zone "innerCylinderSmall" into baffles.

Found 22416 faces on zone "innerCylinderSmall"

Using master patch AMI1 at index 7
Using slave patch AMI2 at index 8
Not converting faces on non-coupled patches.

Reading geometric fields

Reading volScalarField p
Reading volScalarField nut
Reading volScalarField k
Reading volScalarField epsilon
Reading volVectorField U

Problem : Patch AMI1 starts at 1756182
Current face counter at 1756183
Are patches in incremental order?

    From function polyTopoChange::polyTopoChange(const polyMesh& mesh, const bool strict)
    in file polyTopoChange/polyTopoChange/polyTopoChange.C at line 2459.

FOAM aborting

#0  Foam::error::printStack(Foam::Ostream&) in "/opt/OpenFOAM-2.1.1/platforms/linuxGccDPOpt/lib/"
#1  Foam::error::abort() in "/opt/OpenFOAM-2.1.1/platforms/linuxGccDPOpt/lib/"
#2  Foam::polyTopoChange::addMesh(Foam::polyMesh const&, Foam::List<int> const&, Foam::List<int> const&, Foam::List<int> const&, Foam::List<int> const&) in "/opt/OpenFOAM-2.1.1/platforms/linuxGccDPOpt/lib/"
#3  Foam::polyTopoChange::polyTopoChange(Foam::polyMesh const&, bool) in "/opt/OpenFOAM-2.1.1/platforms/linuxGccDPOpt/lib/"
 in "/opt/OpenFOAM-2.1.1/platforms/linuxGccDPOpt/bin/createBaffles"
#5  __libc_start_main in "/lib/"
 at /home/abuild/rpmbuild/BUILD/glibc-2.14.1/csu/../sysdeps/i386/elf/start.S:122

In log.snappyHexMesh I find


Edge intersection testing:
    Number of edges            : 1756183
    Number of edges to retest  : 57
    Number of intersected edges : 75181
Snapped mesh : cells:568602  faces:1756183  points:625033

and in system/changeDictionaryDict I see


            type            cyclicAMI;
            nFaces          0;
            startFace      1756182;
            neighbourPatch  AMI2;
            transform      noOrdering;
            type            cyclicAMI;
            nFaces          0;
            startFace      1756182;
            neighbourPatch  AMI1;
            transform      noOrdering;

TOM01 February 9, 2013 14:55

sorry, that was to early, the solution worked not really

but I found, that it really might be a bug in the tutorial

yhy20081016 October 16, 2013 06:44

You can try the latest version. I had a lot of experience on this issue. I have tried to run the propeller tutorial by using OpenFOAM 2.1.1 on Fedora, but it diverge at t=0.02s. Then I tried the latest version of OpenFOAM --- it works!

All times are GMT -4. The time now is 02:31.