CFD Online Discussion Forums

CFD Online Discussion Forums (
-   OpenFOAM Running, Solving & CFD (
-   -   Wrong results from motorByke tutorial in OpenFoam 2.1.1 (

jsc April 15, 2013 08:07

Wrong results from motorByke tutorial in OpenFoam 2.1.1
Dear all,

The results I get after running the motorBike tutorial are wrong, but I am not getting any error message during execution. Apart from the resulting data everything seems to work properly.

The mesh seems to be correct and I have checked the tutorial files. I have executed other tutorials obtaining the expected results (for simpleFoam and other solvers for incompressible fluid).

Simply I just do not know why only the motorByke tutorial give wrong results and so I cannot rely on any data I could obtain from any execution.:confused:

The only thing I came up with is that I do not have administrator privileges on the computers where I am working with OpenFoam-2.1.1 (which Ubuntu version is 11.04).
The installation directory is "/opt" while in the installation guide it is recommended "/home/OpenFOAM" for user without administrator privileges, but I do not know if this really matters because other tutorials give the expected results.

Any suggestion, solution or explanation will be very appreciated.

Thank you,
José Sánchez.

Post-procesing images of wrong data:



JR22 April 15, 2013 14:04

1 Attachment(s)
Can you confirm that simpleFoam ran, or only potentialFoam (look in the logs). Also, I can see in paraview that you have on the top Time = 0, try using the forward button to the last time step (which should be for simpleFoam). I ran the tutorial using ./Allrun, and got 5 time steps (showed the last one using ). The last one has the velocity profile fully developed (Time=500, #5).

jsc April 15, 2013 17:13

Now I can see the correct results.

Thank you for the advice. I already know that there were 6 time steps but for some reason I was obcecated in that the one displayed was the last one. But as you have shown it was not.

Thank you for your soon answer, I was getting mad checking every file and .log. As you would have notice I am new into OpenFOAM and Paraview.

Thank you very much,
José Sánchez.

jsc April 16, 2013 07:26

The issue is solved, but I do not know why. Because I have found other images from paraview with wrong data and time step 5. Anyway, thank you JR22 for your help.

If someone it is interested next I explain the complet case.

When I first installed openfoam I had problems with paraview. Navigating through this forum I found a solution from wyldcat (close to the end of the next thread):

Running "parafoam" with the option "builtin" solved the problem. Then the problem of the wrong results appeared.

Yesterday, after reading the reply from JR22 I run "parafoam". For some reason (probably exhaustion) I forgot the "-builtin" option. ˇit worked anyway! (it was not suppose to). But I did not realize that I have not used the "-builtin" option so ,as the data displayed was correct, I though that for some reason I have forgotten to change the time steps in paraview all the time (when in reality I have not forgotten).

So now the situation is as follows.

-Although at first "parafoam" only worked with the "-builtin" option and the modification from wyldcat, now works without it.
I have checked the paraFoam file and the modification sugested by wyldcat is gone (I do not remember changing this file :confused:), Everything I changed seems to be exactly as it was when parafoam did not work.
So I do not understand why at first parafoam did not work and now it does (because the only file I change, now it is exactly like it was at first).:confused:

-Now with the option "-builtin" I get in paraview the wrong data. Also the GUI that appears when I run the "-builtin" option has slightly changed. (I guess all of this is normal since the change from wyldcat to make it works has been removed).

So now I do not have any problem (openfoam works and also paraview :)) but I do not now why. Maybe running "paraFoam -builtin" has created any register which solved the issue?

All times are GMT -4. The time now is 18:58.