CFD Online Discussion Forums

CFD Online Discussion Forums (
-   OpenFOAM Running, Solving & CFD (
-   -   mpirun doesn't work after update on 2.2.0 (

marcus85 May 13, 2013 05:33

mpirun doesn't work after update on 2.2.0

i'm new in this Forum and want to ask: if somebody knows a solution for my Problem, please help me:
i've updated only the OpenFOAM Version from 2.0.x on 2.2.0 and now i've the Problem, that mpirun doesn't work any more...
This is the Error-Message, which is posted in the Terminal:
opal_shmem_base_select failed

Also the rhoSimpleFoam solver doesn't work any more, because some Libraries have become new names and new paths, can somebody say me which from the suggested links conforms to this old one out of thermophysicalProperties:
thermoType hPsiThermo<pureMixture<constTransport<specieThermo <hConstThermo<perfectGas>>>>>

The suggested libraries are:

Valid psiThermo types are:

hePsiThermo<homogeneousMixture<const<hConst<perfec tGas<specie>>,sensibleEnthalpy>>>
hePsiThermo<homogeneousMixture<sutherland<hConst<p erfectGas<specie>>,sensibleEnthalpy>>>
hePsiThermo<homogeneousMixture<sutherland<janaf<pe rfectGas<specie>>,sensibleEnthalpy>>>
hePsiThermo<inhomogeneousMixture<const<hConst<perf ectGas<specie>>,sensibleEnthalpy>>>
hePsiThermo<inhomogeneousMixture<sutherland<hConst <perfectGas<specie>>,sensibleEnthalpy>>>
hePsiThermo<inhomogeneousMixture<sutherland<janaf< perfectGas<specie>>,sensibleEnthalpy>>>
hePsiThermo<multiComponentMixture<const<hConst<per fectGas<specie>>,sensibleEnthalpy>>>
hePsiThermo<multiComponentMixture<sutherland<janaf <perfectGas<specie>>,sensibleEnthalpy>>>
hePsiThermo<pureMixture<const<eConst<perfectGas<sp ecie>>,sensibleInternalEnergy>>>
hePsiThermo<pureMixture<const<hConst<perfectGas<sp ecie>>,sensibleEnthalpy>>>
hePsiThermo<pureMixture<const<hConst<perfectGas<sp ecie>>,sensibleInternalEnergy>>>
hePsiThermo<pureMixture<sutherland<eConst<perfectG as<specie>>,sensibleInternalEnergy>>>
hePsiThermo<pureMixture<sutherland<hConst<perfectG as<specie>>,sensibleEnthalpy>>>
hePsiThermo<pureMixture<sutherland<hConst<perfectG as<specie>>,sensibleInternalEnergy>>>
hePsiThermo<pureMixture<sutherland<janaf<perfectGa s<specie>>,sensibleEnthalpy>>>
hePsiThermo<pureMixture<sutherland<janaf<perfectGa s<specie>>,sensibleInternalEnergy>>>
hePsiThermo<reactingMixture<const<hConst<perfectGa s<specie>>,sensibleEnthalpy>>>
hePsiThermo<reactingMixture<sutherland<janaf<perfe ctGas<specie>>,sensibleEnthalpy>>>
hePsiThermo<singleStepReactingMixture<sutherland<j anaf<perfectGas<specie>>,sensibleEnthalpy>>>
hePsiThermo<veryInhomogeneousMixture<const<hConst< perfectGas<specie>>,sensibleEnthalpy>>>
hePsiThermo<veryInhomogeneousMixture<sutherland<hC onst<perfectGas<specie>>,sensibleEnthalpy>>>
hePsiThermo<veryInhomogeneousMixture<sutherland<ja naf<perfectGas<specie>>,sensibleEnthalpy>>>
heheuPsiThermo<egrMixture<const<hConst<perfectGas< specie>>,absoluteEnthalpy>>>
heheuPsiThermo<egrMixture<sutherland<janaf<perfect Gas<specie>>,absoluteEnthalpy>>>
heheuPsiThermo<egrMixture<sutherland<janaf<perfect Gas<specie>>,absoluteInternalEnergy>>>
heheuPsiThermo<homogeneousMixture<const<hConst<per fectGas<specie>>,absoluteEnthalpy>>>
heheuPsiThermo<homogeneousMixture<sutherland<janaf <perfectGas<specie>>,absoluteEnthalpy>>>
heheuPsiThermo<homogeneousMixture<sutherland<janaf <perfectGas<specie>>,absoluteInternalEnergy>>>
heheuPsiThermo<inhomogeneousMixture<const<hConst<p erfectGas<specie>>,absoluteEnthalpy>>>
heheuPsiThermo<inhomogeneousMixture<sutherland<jan af<perfectGas<specie>>,absoluteEnthalpy>>>
heheuPsiThermo<inhomogeneousMixture<sutherland<jan af<perfectGas<specie>>,absoluteInternalEnergy>>>
heheuPsiThermo<veryInhomogeneousMixture<const<hCon st<perfectGas<specie>>,absoluteEnthalpy>>>
heheuPsiThermo<veryInhomogeneousMixture<sutherland <janaf<perfectGas<specie>>,absoluteEnthalpy>>>
heheuPsiThermo<veryInhomogeneousMixture<sutherland <janaf<perfectGas<specie>>,absoluteInternalEnergy> >>

Sorry about my Englisch, that is still not Perfect=)

Thx for your supply...

vatavuk May 14, 2013 08:52

Hi Marcus,
Did you edit the .bashrc file after installing version 2.2?
Best Regards,

marcus85 May 15, 2013 08:15

Hi Paulo,

at first thx for your supply...

yes the Problem with the Bash I solved (bashRC in Home/openfoam/):

if [ -f /etc/bashrc ]; then
. /etc/bashrc

# User specific aliases and functions

#########OpenFOAM 2.2.0 ########
source /usr2/shared1/OpenFOAM/OpenFOAM-2.2.0/etc/bashRCand in the bash file of the OpenFOAM install directory, i typed the following:


if i run something the right version 2.2.0 will be shown in the terminal...

But now i have the Problem, that my old Cases don't run anymore, with the old thermophysicalProperties file and now my Problem is which psiThermo type i've to use to solve my compressible rhoSimpleFoam case...

The Mpirun Problem i also don't fix...Can you say me also sth. for this Problem please.

Many thx...

MfG Marcus

vatavuk May 16, 2013 05:37

Hi Marcus,
What about the tutorials? Did you verify which of them are working correctly and which are not?
Best Regards,

mstachon May 16, 2013 09:23

Same error
Hello, I get the same error after upgrading to OF2.2 on CentOS release 6.4 (Final). For example, tutorials/incompressible/simpleFoam/motorBike :


$ mpirun -np 6 simpleFoam -parallel
It looks like opal_init failed for some reason; your parallel process is
likely to abort.  There are many reasons that a parallel process can
fail during opal_init; some of which are due to configuration or
environment problems.  This failure appears to be an internal failure;
here's some additional information (which may only be relevant to an
Open MPI developer):

  opal_shmem_base_select failed
  --> Returned value -1 instead of OPAL_SUCCESS
[srva1028k:04850] [[INVALID],INVALID] ORTE_ERROR_LOG: Error in file runtime/orte_init.c at line 79
[srva1028k:04850] [[INVALID],INVALID] ORTE_ERROR_LOG: Error in file orterun.c at line 694

vatavuk May 18, 2013 10:12

Hi Marcus and mstachon,
I suspect that some keyword in your installation is not correctly defined, but I don't know how to test this. Were you able to run the parallel breaking dam tutorial that appears in item 2.3.11 of the user guide?
Best Regards,

wyldckat May 18, 2013 12:09

Greetings to all!

@mstachon: This is the second time I see this error message in the last couple of days... check the instructions from here: - post #5

Additionally, since you're using CentOS 6.4, check these installation instructions:

@marcus: Read these instructions: - namely section "Dictionary-based Thermodynamics Selection"

Best regards,

mstachon May 20, 2013 07:05

I have followed the instructions from and now it works! Thanks for the references.

All times are GMT -4. The time now is 20:31.