CFD Online Discussion Forums

CFD Online Discussion Forums (
-   OpenFOAM Running, Solving & CFD (
-   -   sprayEngineFoam problems in 2.2.x (

mturcios777 May 15, 2013 15:09

sprayEngineFoam problems in 2.2.x
Hey everyone,

I'm trying to get some old dieselEngineFoam cases to work with sprayEngineFoam in 2.2.x and am having problems. I have injection which hangs only a few time steps into the profile. Thinking this might be a problem with the engineMesh, I tried changing to fvMotionSolver engineMesh, but the case refuses to start based on a missing keyword, which I don't see how as I'm formatting my dynamicMeshDict like the new pimpleDyMFoam case movingCone.

I really don't get the hanging as I've made the time step and mesh spacing similar to the aachemBomb case (half the resolution actually, but it works with sprayFoam) and am using the same injection profile. I figured if I could get this to work everything should be fine.

The case can be found here:

I've included the first time directory and the last directory before SOI. Try the layered engineMesh first to see the hanging, then switch to the fvMotionSolver to see my problems with fvMotionSolverEngineMesh.

Thanks everyone!

kalle May 15, 2013 16:07

The issue with the motionsolver is due to some confusing changes in 2.2 The issue was elaborated upon here:

Your case takes ages to reach SOI, going from CA -15 to -11. I moved directory -15 to -12 and deleted the -12/uniform directory (to start with nice timestep) and turned chemistry off... lagrangian seems to be running over here, now at CA -9.7 with 1300 parcels injected.


mturcios777 May 15, 2013 18:11

Thanks Kalle. I think I read that bug report before but since it didn't affect me at the time I forgot about it; thanks for letting me know.

I'll confirm that I can get injection to -9.7. On my setup I haven't been able to get anything past -10.95 (if that). If chemistry is truly the issue, then it seems like sprayEngineFoam might be of limited utility. Has anyone done reacting flows with sprayEngineFoam?

mturcios777 May 16, 2013 14:36

Kalle, can you change the SOI to -15 and re-run the case? I tried doing what you suggested and can't get any injection going. Also, what kind of a machine are you running on? I'm wondering if there is a machine specific library problem, or maybe a setting in my OpenFOAM-2.2.x/etc/controlDict that is causing problems. I can't even get injection just running sprayFoam, and I just recompiled my entire installation. Thanks a lot for your help.

kalle May 16, 2013 15:03

I am trying that now. I increased deltaT in /uniform/time by a factor of 1e4 (your CAD/s) to have a reasonable initial deltaT and changed SOI to -15. All other things are as in the case your shared. So for I am on CA=-13.1234 and 1956 parcels.

Meanwhile, I can tell you that I turned on chemistry for my modified case starting at -11, and the case runs, at least to TDC. The case is too cold to have any ignition though, max T ~481 K.

I run serial on Intel i5-3550 CPU @ 3.30GHz, with Ubuntu 12.04 64 bit, and unaltered OpenFOAM 2.2.x (including global controlDict) from March 9.


mturcios777 May 16, 2013 15:35

Thanks a lot. This is starting to look more and more like a machine specific problem. I'm running unmodified OpenFOAM 2.2.x with the latest commit from today. Just rebuilt all libraries and solvers and still not working.

OpenSUSE 12.2 on this machine: (24 GB RAM installed). Has anyone else used sprayEngineFoam with a similar setup?

kalle May 16, 2013 16:11

Night has approached Sweden so I am shutting down. Case is now at -8.7. Additional case with T=1200K @ CA=-15 is also running, now at -10.6... could possibly be machine related - or some recent commits. I'll try again when I have updated my installation.

I would try a "wclean all" in $FOAM_INST_DIR/OpenFOAM-2.2.x and recompile libs and solvers completely from scratch, if I were you.


mturcios777 June 25, 2013 13:07

Hi Karl,

I've been working on other projects and have been keeping this on the back burner. I find that I can get the case to run if I reduce the timestep to something like 1e-9 (the actual deltaT, not the crank angle). What timestep were you able to run it at (sorry its been a while, so I don't expect an immediate reply) just the initial timestep at injection is fine.


kalle June 25, 2013 16:39

I think I did not change your settings. I start at -15 and injection starts at the second time step with "deltaT = 4.95002e-06"... Thought you found it was machine related?


mturcios777 June 25, 2013 16:44

Thanks Karl. I just wanted to make sure that there wasn't anything else going on. I've tried just about everything; reinstalling OpenFOAM from scratch, using the provided MPI (I'm not running in parallel, but there are some PStream calls in the lagrangian), using different versions of C++. Its super frustrating, as we really need sprayFoam to work with these settings. I'm going to try one more time by doing everything from scratch and seeing what I can get to work. If you have any suggestions I would be very grateful, but understand that this is a very strange error to diagnose.

All times are GMT -4. The time now is 10:44.