CFD Online Discussion Forums

CFD Online Discussion Forums (
-   OpenFOAM Running, Solving & CFD (
-   -   Simplefoam phi failure and large mesh's (

drthompson June 16, 2013 21:14

Simplefoam phi failure and large mesh's
Hello All
First thread on the forum!
I am attempting to model a large (68000m2) lagoon in simplefoam with a single inlet and outlet. The purpose of this is to use the steady state velocity as a start point for a tracer solver to determine the residence time in the lagoon. I've sucessfully used simplefoam and the tracer solver before on smaller situations but I'm getting stuck early on with this one.

After sucessfully meshing the lagoon, I run the simplefoam solver and immediatly get a floating point error at time 0 for phi.


Create time

Create mesh for time = 0

Reading field p

Reading field U

Reading/calculating face flux field phi

#0 Foam::error::printStack(Foam::Ostream&) in "/opt/openfoam201/platforms/linux64GccDPOpt/lib/"
#1 Foam::sigFpe::sigHandler(int) in "/opt/openfoam201/platforms/linux64GccDPOpt/lib/"
#2 in "/lib/"
#3 Foam::surfaceInterpolation::makeWeights() const in "/opt/openfoam201/platforms/linux64GccDPOpt/lib/"
#4 Foam::surfaceInterpolation::weights() const in "/opt/openfoam201/platforms/linux64GccDPOpt/lib/"
in "/opt/openfoam201/platforms/linux64GccDPOpt/bin/simpleFoam"
#6 __libc_start_main in "/lib/"
in "/opt/openfoam201/platforms/linux64GccDPOpt/bin/simpleFoam"
Floating point exception
I suspect the problem is something fundermental but I am not sure whether it is size related or something else. I'm in the process of attempting variations on the schemes and relaxation factors etc but have had no luck so far. If anyone has a guess as to why this is occuring, or suggestions to get around, any help would be much appreciated.

nimasam June 17, 2013 00:23

could you post your fvSchemes and your mesh here

drthompson June 23, 2013 17:56

Hello Nima
Thanks for the offer - I managed to solve it.

By rebuilding the entire model from scratch the problem went away. I think what caused this error was something in the mesh to do with local coordinates - I had for the first time tried to alter them, then decided not to (in salome). Not touching them at all as I did the second build avoided whatever happened!

All times are GMT -4. The time now is 21:56.