CFD Online Discussion Forums

CFD Online Discussion Forums (
-   OpenFOAM Running, Solving & CFD (
-   -   The famous floating point exception (

Schroedinger.Cat.AintHere June 27, 2013 15:38

The famous floating point exception
1 Attachment(s)
Hi all,

I have been working with OpenFoam for a while and now I have encountered for the 1st time the famous floating point exception error.

Currently I am working with the DSMC solver with a mesh imported from Ansys. I convert the mesh via the fluentMeshToFoam and then as routine I have done the checkMesh, which did not report any error.

So, I run my dsmcFoam solver without any problems until it is reached the write interval. As soon it is reached this write interval, the simulation crashes.

I really do not know what is the cause of this error :(, any clue :confused:???

I attached a *.txt file with the output error.


immortality June 27, 2013 19:45

check velocity vectors in can help a lot to see whats wrong with BC,also check internalFields
After those,go to change schemes to first order
If not be corrected fine the mesh more.

Schroedinger.Cat.AintHere June 28, 2013 07:24

not looking good ...
Dear Ehsan,

I tried to figured out what you have told me. And I will like to go a bit further on what you pointed out.

I look in the log.dsmcFoam file and it seems that at least the UMean field has been evaluated during the writing interval. However it is actually not writing anything inside the 1st writing time folder: it contains just boundaryT ,dsmcRhoN ,fD, internalE, momentum, rhoM, boundaryU, dsmcSigmaTcRMax ,iDof, linearKE ,q , rhoN und uniform. Any idea why is that :confused:?

About the paraview, the only thing that I can check in paraView are the rhoN, and the rhoM and they are correct. This means that although the simulation is running properly the dsmcFoam solver crashes when it tries to evaluate the fields.

Regarding the mesh, I have already tried 3 different meshes, with different refinements and the problem (dsmcFoam crashed) occurs in the same fashion.

Finally, about changing of the schemes to first order, I did not understand the suggestion. Do you actually mean the fvScheme that is located in the system folder? If so, what do I need to exactly modify and what does this modification implies for the dsmcFoam solver?

Was a bit lengthy the reply, but I am really confused at this point and I do not know what else I can do :confused:

Thank again for the help!

immortality June 28, 2013 07:38

in fact I'm not familiar with this solver.send me your system folder to modify.
run in single processor way to see if the same error occurs.
may it be a bug.

All times are GMT -4. The time now is 20:55.