CFD Online Discussion Forums

CFD Online Discussion Forums (
-   OpenFOAM Running, Solving & CFD (
-   -   Maximum Number of Iteration exceeded (

srahul June 28, 2013 08:48

Maximum Number of Iteration exceeded
Hello Everybody,

I am trying to solve supersonic flow over backstep using rhoCentralFoam and sonicFoambut I m faced with this strange problem :

The error is:
--> FOAM FATAL ERROR : Maximum number of iterations exceeded

From function specieThermo<thermo>::T(scalar f, scalar T0, scalar (specieThermo<thermo>::*F)(const scalar) const, scalar (specieThermo<thermo>::*dFdT)(const scalar) const) const
in file /home/liu/OpenFOAM/OpenFOAM-1.2/src/thermophysicalModels/specie/lnInclude/specie ThermoI.H at line 83.

FOAM aborting

Looking forward to constructive suggestions.


kilroy June 28, 2013 09:30

Hi Rahul,

Are you creating your mesh with some other software and importing it to OpenFoam?

srahul June 29, 2013 02:06

Hello kilroy,

Thanks for posting, I am creating mesh in gambit.

kilroy June 29, 2013 02:09

You may want to look into Dinesh's post below:

"This problem came when I was using the number of interval more than 150 or so, in gambit, the exported mesh to OpenFoam was showing that error message i. e ..Maximum number of iterations exceeded..bla bla.......
before this it was running upto clock time 5 or 6 and than the error message. If I change the mesh intervals, the clock time of getting that massage had been changing accordingly. When I change the mesh intervals in gambit in 100 it worked i.e upto requried time ( ..which I had set in controlDict .....

Conclusion : change (decrease) the mess interval count in gambit. the exported mesh shall let u find the way...."

Hope this helps,


srahul June 29, 2013 03:12


I have aleardy referred to this post, however I had no luck.


kilroy June 29, 2013 03:15


Have you ever tried creating your own mesh by OpenFoam's utilities (blockMesh, snappyHexMesh, etc.)?

srahul June 29, 2013 03:48


I haven't tried that, but there's guy in my lab he works with that and he too faced similar problem.


All times are GMT -4. The time now is 11:09.