CFD Online Discussion Forums

CFD Online Discussion Forums (
-   OpenFOAM Running, Solving & CFD (
-   -   solver compilation problem, /bin/linux64GccDPOpt directory empty (

arnaud6 July 25, 2013 10:48

solver compilation problem, /bin/linux64GccDPOpt directory empty
Hello everybody, this is my first message on the forum and I hope my problem won't be too difficult to solve.

As a first step I am trying to create a new solver from an existing one "channelFoam". I have done all the steps described in the second section of

I have copied the solver "channelFoam" and renamed it to "my_channelFoam". i am working in my user space and not in the installattion space of OpenFOAM.
The error appears when I try to run wmake to compile the new solver.

My message error is


Making dependency list for source file my_channelFoam.C
SOURCE=my_channelFoam.C ;  g++ -m64 -Dlinux64 -DWM_DP -Wall -Wextra -Wno-unused-parameter -Wold-style-cast -Wnon-virtual-dtor -O3  -DNoRepository -ftemplate-depth-40 -I/opt/openfoam171/src/turbulenceModels    -I/opt/openfoam171/src/turbulenceModels/incompressible/LES/LESModel    -I/opt/openfoam171/src/turbulenceModels/LES/LESdeltas/lnInclude    -I/opt/openfoam171/src/transportModels    -I/opt/openfoam171/src/transportModels/incompressible/singlePhaseTransportModel    -I/opt/openfoam171/src/finiteVolume/lnInclude    -I/opt/openfoam171/src/sampling/lnInclude -IlnInclude -I. -I/opt/openfoam171/src/OpenFOAM/lnInclude -I/opt/openfoam171/src/OSspecific/POSIX/lnInclude  -fPIC -c $SOURCE -o Make/linux64GccDPOpt/my_channelFoam.o
/opt/openfoam171/src/finiteVolume/lnInclude/readPISOControls.H: In function ‘int main(int, char**)’:
/opt/openfoam171/src/finiteVolume/lnInclude/readPISOControls.H:11:10: warning: unused variable ‘transonic’ [-Wunused-variable]
/opt/openfoam171/src/finiteVolume/lnInclude/readPISOControls.H:14:9: warning: unused variable ‘nOuterCorr’ [-Wunused-variable]
g++ -m64 -Dlinux64 -DWM_DP -Wall -Wextra -Wno-unused-parameter -Wold-style-cast -Wnon-virtual-dtor -O3  -DNoRepository -ftemplate-depth-40 -I/opt/openfoam171/src/turbulenceModels    -I/opt/openfoam171/src/turbulenceModels/incompressible/LES/LESModel    -I/opt/openfoam171/src/turbulenceModels/LES/LESdeltas/lnInclude    -I/opt/openfoam171/src/transportModels    -I/opt/openfoam171/src/transportModels/incompressible/singlePhaseTransportModel    -I/opt/openfoam171/src/finiteVolume/lnInclude    -I/opt/openfoam171/src/sampling/lnInclude -IlnInclude -I. -I/opt/openfoam171/src/OpenFOAM/lnInclude -I/opt/openfoam171/src/OSspecific/POSIX/lnInclude  -fPIC Make/linux64GccDPOpt/my_channelFoam.o -L/opt/openfoam171/lib/linux64GccDPOpt \
        -lincompressibleLESModels    -lincompressibleTransportModels    -lfiniteVolume    -lmeshTools -lOpenFOAM -liberty -ldl  -lm -o /home/msc/ajc12/OpenFOAM/ajc12-1.7.1/applications/bin/linux64GccDPOpt/my_channelFoam
/usr/bin/ld: cannot find -liberty
collect2: ld returned 1 exit status
make: *** [/home/msc/ajc12/OpenFOAM/ajc12-1.7.1/applications/bin/linux64GccDPOpt/my_channelFoam] Error 1

I have seen in other related posts that the new solver should appear in the $FOAM_USER_APPBIN. If I go to this directory, I can't find anything. The /bin/linux64GccDPOpt has been created but it is empty.

I precise that I am working on a college computer so that I do not have sudo rigths. I tried to set the correct environnement variables using the "source .bashrc" but I still get the error.

From the error message in the terminal window the problem may come from a library problem but I can't solve it.

It's been some time I am working on it and I would be grateful if someone can help me.

Best regards,


All times are GMT -4. The time now is 11:39.