CFD Online Discussion Forums

CFD Online Discussion Forums (
-   OpenFOAM Running, Solving & CFD (
-   -   SimpleFoam time step continuity error (

Josh714 January 13, 2014 13:57

SimpleFoam time step continuity error
Hi all,

Firstly, I'm pretty new to OF so please forgive me if I'm doing something really stupid.

I'm trying to run simpleFoam on a structured O-grid mesh of an aerofoil, generated using this tool: with coordinates that I've put in as a .dat file. However, when I run I'm getting an error in which my time step continuity errors are exploding, as is the bounding nuTilda value.

The error message is as follows:


Time = 51

smoothSolver: Solving for Ux, Initial residual = 0.545925, Final residual = 0.0316233, No Iterations 40
smoothSolver: Solving for Uy, Initial residual = 0.529254, Final residual = 0.0427123, No Iterations 38
#0 Foam::error::printStack(Foam::Ostream&) at ??:?
#1 Foam::sigFpe::sigHandler(int) at ??:?
#2 Uninterpreted:
#3 Foam::PCG::solve(Foam::Field<double>&, Foam::Field<double> const&, unsigned char) const at ??:?
#4 Foam::GAMGSolver::solveCoarsestLevel(Foam::Field<d ouble>&, Foam::Field<double> const&) const at ??:?
#5 Foam::GAMGSolver::Vcycle(Foam::PtrList<Foam::lduMa trix::smoother> const&, Foam::Field<double>&, Foam::Field<double> const&, Foam::Field<double>&, Foam::Field<double>&, Foam::Field<double>&, Foam::PtrList<Foam::Field<double> >&, Foam::PtrList<Foam::Field<double> >&, unsigned char) const at ??:?
#6 Foam::GAMGSolver::solve(Foam::Field<double>&, Foam::Field<double> const&, unsigned char) const at ??:?
#7 Foam::fvMatrix<double>::solveSegregated(Foam::dict ionary const&) at ??:?
#8 Foam::fvMatrix<double>::solve(Foam::dictionary const&) at ??:?
at ??:?
at ??:?
#11 __libc_start_main in "/lib/i386-linux-gnu/"
at ??:?
Floating point exception (core dumped)


I have searched and tried the following:
- Setting gradSchemes in fvSchemes to cellLimited 1. This then causes the simulation to not explode, but it does not converge; it diverges very slowly. After time = 5000 it was still nowhere near converged.
- Running with turbulence off. This obviously removes the nuTilda exploding, but the time step continuity errors still explode.
- Using a coarser mesh. This speeds up the error message appearing, but still doesn't fix the problem.

Using an unstructured mesh using gmsh with all the boundary conditions in the 0 folder the same works fine, and converges no problem.

I can't work out what exactly is causing the problem, and any help or suggestions would be greatly appreciated.

My files are all in the zip file here:

Thanks in advance for any help anyone can give.

harsha_kulkarni August 8, 2014 02:59

Have you solved your problem?????

All times are GMT -4. The time now is 21:58.