CFD Online Discussion Forums

CFD Online Discussion Forums (
-   OpenFOAM Running, Solving & CFD (
-   -   Running Error using Compressible OpenFoam Parallel mode (

dhendria February 13, 2014 21:53

Running Error using Compressible OpenFoam Parallel mode
Hi All,

I'm new with OpenFoam and I'm struggling to run compressible flow in Parallel mode in the environment of Centos 6.5.

I'm trying to run tutorial case:
using 8 core and I keep getting error message. If I run using 1 core, I dont get the error message. The error message only happens with multiple cores even with just 2 core. :confused::confused::confused:

I thought I would be due to the MPI but when I run other tutorial case with incompressible flow, I can make it with multiple cores. Example:
For motoroBike case, I can run it with 6 cores.

Here is the error message (some parts of the error message in the log file) that I got when I tried to run compressible flow:

-- - -- - -
[0] Cannot find patchField entry for procBoundary0to1
[0] file: /home/ccfd/OpenFOAM/OpenFOAM-2.2.2/tutorials/compressible/rhoSimplecFoam/squareBen
d/processor0/0/p.boundaryField from line 25 to line 38.
[0] From function GeometricField<Type, PatchField, GeoMesh>::GeometricBoundaryField::rea
dField(const DimensionedField<Type, GeoMesh>&, const dictionary&)
[0] in file /home/ccfd/OpenFOAM/OpenFOAM-2.2.2/src/OpenFOAM/lnInclude/GeometricBoundaryF
ield.C at line 206.
FOAM parallel run exiting
[1] Cannot find patchField entry for procBoundary1to0
-- - - - - - - -

and Here is the Allrun file that I used to run it:

cd ${0%/*} || exit 1 # run from this directory
# Source tutorial run functions
. $WM_PROJECT_DIR/bin/tools/RunFunctions
runApplication blockMesh
runApplication decomposePar -force
#cp -r 0 > /dev/null 2>&1

#- For parallel running
ls -d processor* | xargs -i rm -rf ./{}/0 $1
ls -d processor* | xargs -i cp -r ./{}/0 $1
foamJob -p -s checkMesh -constant -noZero > log.checkMesh
runParallel patchSummary 8


runParallel $(getApplication) 8
runApplication reconstructParMesh -constant
runApplication reconstructPar -latestTime

# ----------------------------------------------------------------- end-of-file

Do I have any installation problem in my server??:confused: :confused: :confused:
Do I have setting problem in my compressible run???? :confused: :confused: :confused:

Why do I have problem in running compressible flow but not in incompressible flow????

I would appreciate any help ...

Thank you very much in advance.

Dan Hendria

All times are GMT -4. The time now is 18:02.