CFD Online Discussion Forums

CFD Online Discussion Forums (https://www.cfd-online.com/Forums/)
-   OpenFOAM Running, Solving & CFD (https://www.cfd-online.com/Forums/openfoam-solving/)
-   -   Error: "Cannot find file points" related to changing parallelized code to serial? (https://www.cfd-online.com/Forums/openfoam-solving/148441-error-cannot-find-file-points-related-changing-parallelized-code-serial.html)

Suyf February 12, 2015 04:31

Error: "Cannot find file points" related to changing parallelized code to serial?
 
I am an OpenFoam newbie using Ubuntu Linux 14.04 and OpenFoam 2.3.1. I am trying to modify code from someone else, but keep getting the following error:

Quote:

Cannot find file "points" in directory "polyMesh" in times 0 down to constant.
There is discussion of the error in forums, but I don't think I can use it to solve my problem (or maybe I don't understand it). A lot of it is related to the OpenFOAM tutorials and advice seems specific to the tutorials, which I can run no problem.

I think the problem is likely to be related to the fact that I'm running in serial, but the code was made to run in parallel. The reason I think this is that I have two "processor" files in my run directory. Inside each processor file is a "points" file (under constant/polyMesh). In the run directory under 0/polyMesh, there are no files. Here is what I have tried so far:

In the run directory under system, I tried modifying "decomposeParDict" by changing "numberOfSubdomains 2" to "numberOfSubdomains 1" and also deleting the processor files. I got an error:

Quote:

Cannot open mesh description file
constant/polyMesh/blockMeshDict
This made sense because there was no blockMeshDict in that location. Next, I copied blockMeshDict there from the "system" directory. I then got an error that file p_rgh was missing from run directory/0/p_rgh. I found that file in each processor directory, so picked one and moved it to /0. Now I'm getting:

Quote:

Cannot find patchField entry for XXX
file: /0/p_rgh.boundaryField
I think this is related to boundary conditions, but I don't know what to do next. I guess my question is, am I on the right track that my problem is likely to be related to parallel/serial? If I am, is there a simple recipe for changing from parallel to serial?


All times are GMT -4. The time now is 19:33.