CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > Software User Forums > OpenFOAM > OpenFOAM Running, Solving & CFD

OpenFoam parallel running log issue

Register Blogs Members List Search Today's Posts Mark Forums Read

Reply
 
LinkBack Thread Tools Search this Thread Display Modes
Old   January 19, 2016, 08:37
Default OpenFoam parallel running log issue
  #1
Member
 
gereksiz
Join Date: Mar 2015
Posts: 42
Rep Power: 8
clktp is on a distinguished road
Hello,

When I run something parallel, there isn't anything written in log file, however, when it's serial there isn't any problem.

I'm using this command.
mpirun -np 2 simpleFoam -parallel > log &

I have the log file only after it's completed. It's really annoying, because I can't check the residuals or how much time I need.

I checked the forum a bit, but I couldn't find any solution or see anybody had this problem.

Regards,
clktp is offline   Reply With Quote

Old   January 19, 2016, 08:59
Default
  #2
Member
 
Pascal Balz
Join Date: Feb 2015
Location: Germany
Posts: 44
Rep Power: 8
pbalz is on a distinguished road
Hi,

Code:
mpirun -np 2 simpleFoam -parallel | tee log.simpleFoam
works well for me, and gives you the terminal output + the log file.
__________________
Regards,
Pascal
pbalz is offline   Reply With Quote

Old   January 19, 2016, 09:12
Default
  #3
Member
 
gereksiz
Join Date: Mar 2015
Posts: 42
Rep Power: 8
clktp is on a distinguished road
it works very well, thank you very much!
clktp is offline   Reply With Quote

Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Error running simpleFoam in parallel Yuby OpenFOAM Running, Solving & CFD 13 April 17, 2017 16:27
openfoam pow() fails when running parallel Carlen OpenFOAM Programming & Development 9 February 23, 2015 02:02
Suggestion for a new sub-forum at OpenFOAM's Forum wyldckat Site Help, Feedback & Discussions 20 October 28, 2014 09:04
parallel running issue in ansys 14 fluent ade4921 FLUENT 3 March 6, 2014 05:35
Running Error using Compressible OpenFoam Parallel mode dhendria OpenFOAM Running, Solving & CFD 0 February 13, 2014 20:53


All times are GMT -4. The time now is 07:03.