CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > Software User Forums > OpenFOAM > OpenFOAM Running, Solving & CFD

interFoam problems with stability

Register Blogs Members List Search Today's Posts Mark Forums Read

Like Tree2Likes
  • 2 Post By vatavuk

Reply
 
LinkBack Thread Tools Search this Thread Display Modes
Old   November 18, 2016, 14:38
Default interFoam problems with stability
  #1
Member
 
Federico Zabaleta
Join Date: May 2016
Posts: 38
Rep Power: 7
fedez91 is on a distinguished road
Dear Foamers,

I'm giving my first steps with 3D interFoam simulations, and I have some problems with the stability a model:

I'm trying to simulate a 3D channel with a derivation, which has a small step in it. The inlet consist of a constant volumetric flow (200 m3/s), and the two outlets consist of a spillway (to control the water level) and a gate (Check the images for a clearer explanation)

The problem is that I cant reach to a stable solution, because the simulations breaks before getting to a stationary state (Usually breaks between 40s and 110s).

More info:
OF version: 3.0.0
RAS Model: k-epsilon
U Inlet: VolumetricFlowRate (Advancing from 0 to 200)
U Outlet: zeroGradient
Mesh: From ICEM
Other parameters: From dambreak

I've been like two weeks trying to make it work, I've tried to change a lot of parameters, but still can't make it.

With this thread I attach the case and some pictures.
I would really appreciate any advice or recommendation from interFoam experienced users.
Please ask me if you need more information.

FoamCase:
https://drive.google.com/open?id=0B4...GNNNmNHcGZVMTA
fedez91 is offline   Reply With Quote

Old   November 23, 2016, 09:37
Default
  #2
Member
 
Federico Zabaleta
Join Date: May 2016
Posts: 38
Rep Power: 7
fedez91 is on a distinguished road
Any advice? At the beginning I was having problems with k-epsilon initial conditions. I was using very low values of k-epsilon (around 1E-4). Then I changed them to 0.1 (like in dambreak). Maybe the problem is there.

What are the usual values for initial conditions?
fedez91 is offline   Reply With Quote

Old   November 25, 2016, 04:48
Default
  #3
Senior Member
 
Paulo Vatavuk
Join Date: Mar 2009
Location: Campinas, Brasil
Posts: 191
Rep Power: 14
vatavuk is on a distinguished road
Hi Frederico,

For p_rhg, in the inlet, you should use the fixedFluxPressure boundary condition. The zeroGradient condition in the inlet makes interfoam unstable. See the discussion in http://bugs.openfoam.org/view.php?id=2013

Best Regards,
Paulo
imano and fedez91 like this.
vatavuk is offline   Reply With Quote

Old   November 30, 2016, 09:36
Default
  #4
Member
 
Federico Zabaleta
Join Date: May 2016
Posts: 38
Rep Power: 7
fedez91 is on a distinguished road
Dear Paulo,

Thank you very much for your answer.
I tried it and it worked ok!

Best Regards,
fedez91 is offline   Reply With Quote

Reply

Tags
intefoam

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
interFoam stability issue, free surface ship hull jojosaxo OpenFOAM Running, Solving & CFD 5 July 7, 2016 18:29
k-e & GAMG interFoam Schemitisation Stability Issue JFM OpenFOAM Running, Solving & CFD 3 December 1, 2015 06:58
interFoam Stability Issues Dazzler OpenFOAM Running, Solving & CFD 3 March 12, 2015 03:04
Stability problems with kepsilon in external aero edreed OpenFOAM Running, Solving & CFD 21 July 16, 2008 16:00
Problems involving interFoam and GCC 410 gschaider OpenFOAM Installation 1 July 30, 2006 20:58


All times are GMT -4. The time now is 22:39.