CFD Online Discussion Forums

CFD Online Discussion Forums (https://www.cfd-online.com/Forums/)
-   OpenFOAM Running, Solving & CFD (https://www.cfd-online.com/Forums/openfoam-solving/)
-   -   reactingFoam with Gri-Mech 3.0: No combustion happening (https://www.cfd-online.com/Forums/openfoam-solving/182305-reactingfoam-gri-mech-3-0-no-combustion-happening.html)

a_slow_old_man January 6, 2017 05:12

[Solved] reactingFoam with Gri-Mech 3.0: No combustion happening
 
2 Attachment(s)
Solved: Use more heat.


Hello cfd-online community,

I am working on my bachelors Thesis and part of it is evaluating different reaction mechanisms for methane combustion.

I used the reactingFoam tutorial counterflow flame Case (../tutorials/combustion/reactingFoam/ras/counterFlowFlame2D) to test a global 1-Step, 2-Step, 4-Step and GRI-Mech 3.0 reaction.


With the tutorial 1-Step Case I get the typical flamefront, reaction, and species-fraction along the axis as expected.

Using the adjusted reaction rates described in "Simplified Reaction Mechanisms for the Oxidation of Hydrocarbon Fuel in Flames"
by C.K. Westbrook and Frederick. L. Dryer to determine the activation energy and pre-exponential factor for my own 1-Step, 2-Step, 4-Step reaction or using the GRI-Mech 3.0 reaction I dont have a reaction. There is a slight rising in temperature but this also accurs in a case with combustion and reaction turned off. Even when increasing the inlet temperatur of air and fuel to 1000K (Autoignitionpoint of Methane 810K according to wikipedia) I have no real reaction.

Am I missing something obvious? Why is there no reaction?


Trying the same values (with k-Epsilon turbulence model) on a piloted flame Case [similar to Sandia Flame D but a little sloppy] I have the same problem. Using the 1-Step combustion from the tutorial Case it works, with GRI-MECH 3.0, just a very small region of reaction very close to the inlet.

I am attaching the pilotedFlame and CounterflowFlame case of my GRI-MECH 3.0 Cases.

If anyone finds my error or had this problem before, please tell me. I am at a loss as to why this is happening, or rather... not happening.



EDIT: I solved my problem by using the highly scientific method of using way more heat.

Applying 1200K at both air and fuel inlet finally gave me the desired reaction profile. A external ignition via fvOptions also worked.


All times are GMT -4. The time now is 22:45.