CFD Online Discussion Forums

CFD Online Discussion Forums (https://www.cfd-online.com/Forums/)
-   OpenFOAM Running, Solving & CFD (https://www.cfd-online.com/Forums/openfoam-solving/)
-   -   Unable to open .unv file while using ideasUnvToFoam - Foam Fatal Error (https://www.cfd-online.com/Forums/openfoam-solving/226376-unable-open-unv-file-while-using-ideasunvtofoam-foam-fatal-error.html)

boombaala April 25, 2020 05:16

Unable to open .unv file while using ideasUnvToFoam - Foam Fatal Error
 
1 Attachment(s)
Greetings, I am a new OpenFoam user with background in Mechanical Design. I am using OpenFoam 19.12 on Windows 10.

Here, I am trying to perform a CFD on a Propeller Fan by following a tutorial. I have mesh in .unv file (that I created on Salome) that I want to convert to the foam format to be able to perform CFD. However, I am getting an Error saying (See attached Picture)

--> FOAM FATAL ERROR:
Cannot Open "File ___.unv"

From function int main(int, char**)
in file ideasUnvToFoam.C at line 673.


The problem is, I am unsure how to interpret this error and what steps I should take to learn how to solve such errors and move forward. I have done some research by reading the "OpenFoam User Guide Version 7", and also tried googling and looking up some of the similar forum questions. However, I couldn't figure out what to make of this error and go ahead.

I would really appreciate any help. Thank you in advanced.

P.S. I humbly apologize if this type of error is basic, but I am not really strong with this programming language.

Berkk July 9, 2020 09:10

Hello,

I have same problem and I guess this problem exists for new OpenFOAM users. The difference is that I am using OpenFOAM on Ubuntu 18.04 LTS on Windows 10. But, "From function int main(int, char**) in file ideasUnvToFoam.C at line 673" error is exactly the same here. I just changed something in mesh quality as first thing that comes to mind. But, I could not solve this problem.

This error came from the line below.

"
int main(int argc, char *argv[])
{
argList::addNote
(
"Convert I-Deas unv format to OpenFOAM"
);
argList::noParallel();
argList::addArgument(".unv file");
argList::addBoolOption
(
"dump",
"Dump boundary faces as boundaryFaces.obj (for debugging)"
);

#include "setRootCase.H"
#include "createTime.H"

const fileName ideasName = args[1];
IFstream inFile(ideasName);

if (!inFile.good())
{
FatalErrorInFunction
<< "Cannot open file " << ideasName
<< exit(FatalError);
}
"

I will check on my boundary faces and mesh quality, again. If I could find a way to solve, I will let you know.

By the way, did you solve it ?

Thanks in advance.

avdhruva October 3, 2020 13:42

I am also facing the same problem. Please update if you find any solution to this problem.

Ashwin2206 October 21, 2020 05:01

Same Error
 
I am also facing the same error, where the system displays Fatal Error as the unv file cannot be opened.
Please do let me know if you have resolved this error and if so, how it was done.

julieng February 22, 2021 11:01

Hello,


Same problem here.
Do you solve the problem?


Julien


All times are GMT -4. The time now is 14:46.