CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > Software User Forums > OpenFOAM > OpenFOAM Running, Solving & CFD

Errors when running parallel in different versions of openfoam

Register Blogs Members List Search Today's Posts Mark Forums Read

Reply
 
LinkBack Thread Tools Search this Thread Display Modes
Old   November 16, 2021, 22:28
Default Errors when running parallel in different versions of openfoam
  #1
New Member
 
Jin Zhang
Join Date: May 2018
Location: Germany
Posts: 13
Rep Power: 6
sjlouie91 is on a distinguished road
Dear foamers,
Previously I installed of5 and of7 in my computer and it all ran well in parallel. However, recently I installed of8 and I can run solvers in parallel with this version, while I cannot run in parallel with of5 and of7. The error message is shown in the following figure. I guess it is due to the libMPI is changed. But I have no idea how to handle this problem. Do you have any suggestions how it solve this problem?
Attached Images
File Type: jpg error.jpg (82.5 KB, 8 views)
sjlouie91 is offline   Reply With Quote

Old   November 17, 2021, 04:17
Default
  #2
Senior Member
 
Kumaresh
Join Date: Oct 2016
Posts: 317
Rep Power: 8
Kummi is on a distinguished road
Send a message via Yahoo to Kummi
Hello Jin Zhang,
The following links might help you
mpirun not working in paralleö with OpenMPI
mpirun suddently dosent work
Running OpenFOAM on a Cluster
Error running openfoam in parallel
Kummi is offline   Reply With Quote

Old   November 23, 2021, 22:09
Default
  #3
New Member
 
Jin Zhang
Join Date: May 2018
Location: Germany
Posts: 13
Rep Power: 6
sjlouie91 is on a distinguished road
Hi. Thanks so much for sharing the link. However I haven't solved it yet.
sjlouie91 is offline   Reply With Quote

Reply

Tags
libmpi, of5, of8, parallel, ubuntu18.04

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Error when running OpenFOAM parallel on WSL wyj216 OpenFOAM Running, Solving & CFD 1 July 7, 2021 03:10
Running OpenFOAM parallel with different OpenFoam directories? massive_turbulence OpenFOAM Running, Solving & CFD 0 November 19, 2018 15:08
Kubuntu uses dash breaks All scripts in tutorials platopus OpenFOAM Bugs 8 April 15, 2008 07:52
IcoFoam parallel woes msrinath80 OpenFOAM Running, Solving & CFD 9 July 22, 2007 02:58
Could anybody help me see this error and give help liugx212 OpenFOAM Running, Solving & CFD 3 January 4, 2006 18:07


All times are GMT -4. The time now is 02:52.