CFD Online Discussion Forums

CFD Online Discussion Forums (
-   OpenFOAM Running, Solving & CFD (
-   -   Pressure losses in a 3d pipe with RANS (

ariorus January 27, 2009 05:13

Hello, I am running a simpl

I am running a simple 3d pipe (the section changes from inlet to outlet, from a square section to a circular section).
I am obtaining bad results: the pressure loss seems too large, compared with the same case run by cfx.

I have tested different Reynolds number and the results are correct only in laminar flow.
The problem seems somehow correlated with the turbulent model but there are problems also at the outlet where there is a sudden change in pressure as it is showed in the attached picture.

I thought that the problem was due to the too short pipe length (the velocity field is still changing at the outlet section), but looking at the picture reporting velocity the changing at outlet seems very slow..

I have tried different discretization schemes, different turbulent models but nothing changes.

By the way the computation converges without problems and the y+ are fairly at maximum around 40.
I'm attaching here also the screenshots of other fields.

In cfx with the same geometry, the same mesh(even if the mesh is not strictly the same since cfx uses value at grid nodes) the same turbulent model and the same values at inlet for turbulent quantities, the pressure variation at outlet is smooth and the pressure loss from inlet to outlet is lower. The grid is made by tetra and prisms at the walls. Checking the mesh by checkMesh everything is fine.

I used fixedValue for velocity and zeroGradient for pressure at inlet, and fixedValue for pressure and zeroGradient for velocity at outlet.

I have also tried to use OutletInlet boundary condition at the outlet for pressure and inletOutlet for velocity (and turbulent quantities) but it didn't help.

Did anybody have ever had similar problems?
Am I missing something obvious?

ariorus January 27, 2009 05:26

ariorus January 27, 2009 05:28

ariorus January 27, 2009 05:30

ariorus January 27, 2009 05:32

ariorus January 27, 2009 05:34

ariorus January 29, 2009 07:58

Problem solved. It was my f
Problem solved.

It was my fault of course... :-P
I had compiled some customized BCs and must have touched something I didn't want...
I recovered the original version and now everyhing seems ok.

All times are GMT -4. The time now is 04:30.