CFD Online Discussion Forums

CFD Online Discussion Forums (
-   OpenFOAM Running, Solving & CFD (
-   -   IcoDyMFoam New cannot satisfy memory request (

yuhai December 9, 2008 18:23

hello, everybody, I am a begi
hello, everybody,
I am a beginner of OF.
I have tried three subversions of 1.4.1-dev, with the tutorial "mixer2D",
but it always stops at the first step:
Create dynamic mesh for time = 0

Selecting dynamicFvMesh mixerFvMesh
Rotating region marker point: (0 0 0)
Attach-detach action = false
Time = 0
Adding zones and modifiers to the mesh
new cannot satisfy memory request.
This does not necessarily mean you have run out of virtual memory.
It could be due to a stack violation caused by e.g. bad use of pointers or an out of date shared library
I don't know what is the reason.
Thanks in advance.

Yu Hai

hjasak December 9, 2008 19:35

There is something wrong with
There is something wrong with your installation of library. I cannot say what based on the current information - the same code runs fine here.

Sorry I cannot help more,


naish December 10, 2008 06:15

Hello Yu Hai Is the Mesh the
Hello Yu Hai
Is the Mesh the original size or did you increase the number of nodes.
I had the same error message with a large model when I changed to a 64bit machine it works.

By the way I'm also playing around with icoDyMesh Foam but in the new 1.5 version mixerFVMesh is not anymore included in icoDyMesh.
I know how that I have to include it but I do not know where and how.

does anybody can tell me


All times are GMT -4. The time now is 21:05.