CFD Online Discussion Forums

CFD Online Discussion Forums (
-   OpenFOAM Running, Solving & CFD (
-   -   A question on the first tutorial example bcavityb (

athlonshi October 21, 2008 16:45

Hi all: I just installed Open
Hi all:
I just installed OpenFOAM 1.5 successfully and was able to run the first tutorial 'cavity' up to post-processing.
The problem that I encountered was that the blockMesh program worked fine and so did the icoFOAM, but I didn't find any case file which was supposed to be 'cavity.foam' in that folder or even other places that I searched. I was wondering where the result file was located and is it possible that I messed up the system path which might cause this problem? Thanks.

gwierink October 22, 2008 02:46

Hi Yu, Try running the case
Hi Yu,

Try running the case in ParaView from the command line, i.e. go to the cavity directory and type "paraFoam". Or. I think, the 1.4.1 version of that should also still work: go to the directory where cavity lives and type "paraFoam . cavity".



markusrehm October 22, 2008 02:47

Hi Yu, as far as I know and
Hi Yu,

as far as I know and interpret your posting you mean the cavity.OpenFOAM mentioned in UG 2.1.2. This is automatically generated when you start paraFOAM and you will not really need it.

Regards and a lot of fun with OF, Markus.

athlonshi October 22, 2008 09:12

Thanks, Gijs and Markus! I fo
Thanks, Gijs and Markus!
I followed the UG2.1.2 but received the following message
ERROR: In ~/OpenFOAM/ThirdParty/ParaView3.3-cvs/Servers/Filters/vtkPVDReader.cxx, line 148
vtkPVDReader (0x9840d58): Could not read file information

ERROR: In ~/OpenFOAM/ThirdParty/ParaView3.3-cvs/VTK/Filtering/vtkExecutive.cxx, line 757
vtkCompositeDataPipeline (0x90fca48): Algorithm vtkPVDReader(0x9840d58) returned failure for request: vtkInformation (0x97d6760)
Debug: Off
Modified Time: 80913
Reference Count: 1
Registered Events: (none)

ERROR: In ~/OpenFOAM/ThirdParty/ParaView3.3-cvs/Servers/Common/vtkPVDataInformation.cxx, line 493
vtkPVDataInformation (0x98516d8): Could not cast object to a known data set: vtkAlgorithmOutput
It seems to me that the ParaView cannot found the data file somehow.

Then I tried to convert the results to VTK format using FormTOVTK, and it worked. Still, I am interested what I was wrong when I followed the UG or there might be some problems when I installed it. Thanks again.

gwierink October 22, 2008 12:19

Hi Yu, It seems you have th
Hi Yu,

It seems you have the same proble I had when I tried to install OpenFOAM-1.5 with ParaViwe3.3. It is mentioned in section 7 in the OpenFOAM-1.5 README file, you probably need to rebuild ParaView and make sure you have Qt-4.3.x (and also you may need some openGL headers, as Bernhard Gschaider mentions in this thread). This and this thread deal with the same or similar issue. I have not had enough time yet to fix it, but if I will I will let you know. For now, if you work it out, please post it. Thanks in advance.

Cheers, Gijs

athlonshi October 22, 2008 21:47

Hi,Gijs: The platform folder
The platform folder has been deleted though took a long time. However, when i failed to rebuild the paraview using buildParaView3.3-cvs
After passing all checks, it left me
"make: *** No targets specified and no makefile found. Stop."

I think I need to contact our system administrator to see what to do next. Thanks.

gwierink October 23, 2008 02:38

Hi Yu, I had a similar prob
Hi Yu,

I had a similar problem, haven't solved it yet though. I will let you know if I get it to work.



athlonshi October 23, 2008 11:28

Gijs: Our system administrato
Our system administrator helped me to install the OpenFOAM on our server and I have successfully run a few tutorial cases. According to him, it is not necessary to rebuild the paraview. And the problem that we have encountered are most likely due to a wrong path specified. Thanks.
Good luck!

All times are GMT -4. The time now is 04:33.