CFD Online Discussion Forums

CFD Online Discussion Forums (
-   OpenFOAM Running, Solving & CFD (

msrinath80 October 15, 2006 20:34

Can someone help me with this
Can someone help me with this error message that shows up when I run icoFoam in parallel.

[0] --> FOAM FATAL IO ERROR : Expected a '(' while reading VectorSpace<form,>, found on line 0 the doubleScalar 13.2233
[0] file: IOstream at line 0.
[0] From function Istream::readBegin(const char*)
[0] in file db/IOstreams/IOstreams/Istream.C at line 94.

mattijs October 16, 2006 04:33

Check which file that number i
Check which file that number is in. Something is trying to read a vector/point.

set the environment variable FOAM_ABORT and run the different processes each in a different window in a debugger. Have a look at the lamrun script (posted here before)

msrinath80 October 17, 2006 02:16

Thanks Mattijs. I solved the p
Thanks Mattijs. I solved the problem somehow. I'll soon post the solution here. Once again, I appreciate your help

mgz1985 July 30, 2008 06:07

hi pUI, relating to ur post
hi pUI,

relating to ur post of doubleScalar errors, can u plese tell me the solutionas i m facing the same problem while defining a arc or a spline as an edge in openfoam 1.5

msrinath80 July 30, 2008 10:06

Hi Mayanak, My sincere apol
Hi Mayanak,

My sincere apologies. It was a long time ago and I'm not sure if I remember what I did to overcome the problem. I do remember that this was something to do with a wrong definition in one of the dictionary files, not to do with any code. I'll try to look into my scrap notes and see if I can figure this out. Once again, very sorry.

All times are GMT -4. The time now is 02:08.