CFD Online Discussion Forums

CFD Online Discussion Forums (
-   OpenFOAM Running, Solving & CFD (
-   -   Parallel runs using LAM (

sek October 25, 2007 13:46

Did I have to get LAm from som
Did I have to get LAm from somehwere? When I type lamboot -v .. it says lamboot coomand not found.

msrinath80 October 25, 2007 14:30

OpenFOAM now uses OpenMPI. Ple
OpenFOAM now uses OpenMPI. Please refer to the latest user guide for details. If you choose to use LAM, you will need to build it.

gabriel October 25, 2007 17:36

It is well documented on pages
It is well documented on pages 62 and 63 of the user guide. decompose the domain using decomposePar <root> <case>. The decomposParDict you can take from the brake of a dam tutorial case. After that you can run on a multiple processor/core machine with the command

mpirun -np <numberofprocessors> <solver> <root> <case> -parallel > log &

sunny October 27, 2007 06:25

Hello there. Does anyone know
Hello there. Does anyone know how to implement parallel processing with the mpich2sub command in OpenFOAM? I tried it but it doesn't seem to work with the -parallel option.


braennstroem February 8, 2008 13:12

Hi, due to my openmpi probl

due to my openmpi problems I would like to try 'lam' for 1.4.1 version.
Do I have to to recompile the whole OpenFoam src directory after I changed the WM_MPILIB variable? Maybe there is a chance to use the existing lam as well?


thomas February 9, 2008 05:49

Hi Fabian, which openMPI-Pr
Hi Fabian,

which openMPI-Problems do you have? I have used lam, mpich and now openmpi, and with openmpi I had nearly no problems. Also notice that lammpi is no longer developed and openmpi is the official follower - so maybe your problems will not vanish by using lam.

For using lam: As far as I know you just have to reompile the Pstream library after changing the corresponding switch to lam.


braennstroem February 11, 2008 10:47

Hi Thomas, thanks for your
Hi Thomas,

thanks for your help. My openmpi-PBS system run call
looks like:
mpirun np 4 simpleFoam . E1_SEHR_SST -parallel > log

It runs all 4 processes on one cpu; which happens due the missing hostfile, I think.

But the other call:

mpirun -hostfile $PBS_NODEFILE -np 4 simpleFoam . E1_SEHR_SST -parallel > log

does not work at all...!? I actually do not have any idea anymore and have to wait for an answer of my administrator. In the meanwhile I wanted to try lam. By the way, how do I recompile the 'Pstream library'? Is it the whole src directory with the Allwmake call and the corresponding MPILIB switch or is there a shorter way?

Would be nice, if you have an idea :-)

thomas February 11, 2008 13:22

Hi Fabian, are you using th
Hi Fabian,

are you using the newest OF-version 1.4.1 together with a queuing system?

If yes, try to get rid of -hostfile $PBS_NODEFILE in your call. Don't ask why, this worked with openmpi 1.2.1, but not with 1.2.3. Also at the end exchange > log with >& log, so you also stream the error output into your log file.

As far as I remember you just have to change the WM_MPLIB-Switch under OpenFOAM-1.4.1/.OpenFOAM-1.4.1/bashrc
in line 126 and if you type Allwmake in your src directory only the necessary libraries are rebuild.


braennstroem February 11, 2008 13:25

Hi, me again... The lam comp
me again...
The lam compilation and pstream works on my local machine with no problem. Is it possible to clean the directory and copy the working openfoam from local machine to the cluster. I am afraid that some path settings could make trouble!?


braennstroem February 11, 2008 14:00

Hi Thomas, yes, the newest
Hi Thomas,

yes, the newest 1.4.1 with a pbs queuing system. I actually tried to get rid of the 'hostfile', but how does openfoam/openmpi then know, how to distribute the domains? As mentioned above, all processes run on one node!?
The compilation on the cluster does not work due to disk quota problems :-((


thomas February 11, 2008 14:25

I think I found a hint on tis
I think I found a hint on tis startup problem somewhere in google.

But as I said, I don' know. I think openmpi recognizes to be run within a queueing systems and is somewhat compatible to it - that's just a suggestion.

But it works, distribution of all processes is fine, so just try - hop it works!


braennstroem February 13, 2008 08:36

Hi Thomas, now it works :-)
Hi Thomas,

now it works :-)
I had to recompile openmpi with the "--with-tm" Option and defining the pbs binary directory. Unfortunately, it did not work as hoped in the begining due to a compiling error with gcc (see: )

Thanks for your help!

All times are GMT -4. The time now is 23:49.