CFD Online Discussion Forums

CFD Online Discussion Forums (
-   OpenFOAM Running, Solving & CFD (
-   -   Differences between 32bit and 64bit results (

philippose November 8, 2007 07:21

Hello, Quick question.... i

Quick question.... is it normal to see large differences in simulation convergence, and significant differences in the results between a 32bit and 64bit run of the same case using simpleFoam??

The 64-bit simulation was run on an AMD X2 (but using only one processor), and the 32-bit version on an Intel Quad-Core (but with OpenFOAM compiled without the WM_64=on option... and again using one processor).

The 64-bit simulation has convergence values at around 760 iterations, which are comparable to those seen at around 1600 iterations on the 32-bit simulation

Moreover.. the results are disturbingly different.

I use the AMG solver for pressure, and the PBiCG for the other fields.

I am not 100% sure anymore if both the systems use the exact same version of OpenFOAM, though both use the OpenFOAM-1.4.1 release (one could be a development release from the Powerlab ftp).

Hoping for an explanation.....


msrinath80 November 8, 2007 11:24

Philippose, I remember Frank m
Philippose, I remember Frank mentioning this. He found different results between OF 1.3 and 1.4 for the moving mesh cases. This may have nothing to do with 32/64 bit architecture. Are you trying a moving mesh case as well?

philippose November 8, 2007 13:38

Hi again, Nope... this is n
Hi again,

Nope... this is not a moving mesh case. As I had mentioned... it was a simple system using the plain vanilla "simpleFoam" solver from OpenFOAM.

Thing is... I had compiled a new version of OpenFOAM on the AMD Dual core using the "WM_64=on" option to enable 64-bit code about a month or so back.

Two days ago, I ran a simulation on this computer, and then... I ran a couple more similar cases on a Quad-Core, which is running an older version of OpenFOAM, but still of the 1.4.1 breed (however, mistakenly compiled without the "WM_64=on" option, making it a 32-bit version).

Today I noticed that the results of the simulations of the "similar" cases were unexpectedly different from the case run on the Dual Core.

So as a test, I ran the same case which was run on the Dual Core, on the Quad Core without any changes to the case structure..... and found that here too, I get unexceptable differences mainly in the pressure distribution (I did not check the "k" and "epsilon" distributions).

A couple of hours ago I recompiled the latest SVN version of OF-1.4.1-dev on the Dual Core. I shall copy it into the Quad Core tomorrow and run the simulation again on both to see what happens.

What surprised me was the rate at which the 64-bit one converged (or the lack of convergence on the 32-bit), and also.... on the 32-bit version, I started getting "bounding" messages for Epsilon, which was not the case in the 64-bit version.

Has anyone else experienced such phenomena? Something like this would be enough for people to start doubting simulation results unless it can be explained.

Have a nice day!


msrinath80 November 8, 2007 13:55

Philippose, do pack your case
Philippose, do pack your case and post it here. I will give it a try on the clusters I have access to.

philippose November 9, 2007 14:17

Hello Srinath, Good Evening
Hello Srinath,

Good Evening!

As I had mentioned, yesterday I compiled the latest version of OpenFOAM-1.4.1-dev from SVN with the 64-bit option enabled.

Today I installed it on both the computers (The AMD64 X2, as well as the Intel Quad Core), and re-ran the same simpleFoam simulation case.

This time, both the results ended up being the same (whew :-)!).... so I guess that part of the problem is solved...

However, now arises the question..... how come the two OpenFOAM-1.4.1 installations I had earlier, came up with drastically different results?

I shall see if I can find the screen-shots I made of the difference on Monday.... but to me... its quite scary that one "subversion" of OF-1.4.1 compiled as 32-bit on a 64-bit Intel machine would give very different results compared to another "subversion" of OF-1.4.1 compiled as 64-bit on a 64-bit AMD machine.

Anyway.... not to jump to conclusions.... shall try to recreate the situation sometime next week....

Does anyone have any ideas?

Have a nice weekend!


All times are GMT -4. The time now is 17:28.