CFD Online Discussion Forums

CFD Online Discussion Forums (
-   OpenFOAM Running, Solving & CFD (
-   -   Problem in running Parallel (

mamaly60 October 27, 2007 12:43

Hello, I installed OF in /w

I installed OF in /work/mou/OpenFOAM/..., When I run "mpirun -np 4 interFoam . damBreak -parallel" and it worked perfect. but I know that it run 4 processes in 1 processor, because for having real parallelization I need to submit my job to the queue in cluster. When I use this command:"sqsub -q mpi -n 4 -o test.log interFoam . damBreak -parallel" it give me error.

srun: error: req555: task2: Aborted
srun: Terminating job

--> FOAM FATAL ERROR : bool Pstream::init(int& argc, char**& argv) : attempt to run parallel on 1 processor#0 Foam::error::printStack(Foam: in "/work/mou/OpenFOAM/OpenFOAM-1.4.1/lib/linuxGccDPOpt/"
#1 Foam::error::abort() in "/work/mou/OpenFOAM/OpenFOAM-1.4.1/lib/linuxGccDPOpt/"
#2 Foam::Pstream::init(int&, char**&) in "/work/mou/OpenFOAM/OpenFOAM-1.4.1/lib/linuxGccDPOpt/openmpi-1.2.3/ "
#3 Foam::argList::argList(int&, char**&, bool, bool) in "/work/mou/OpenFOAM/OpenFOAM-1.4.1/lib/linuxGccDPOpt/"
#4 main in "/work/mou/OpenFOAM/OpenFOAM-1.4.1/applications/bin/linuxGccDPOpt/interFoam"
#5 __libc_start_main in "/lib/tls/"
#6 Foam::regIOobject::readIfModified() in "/work/mou/OpenFOAM/OpenFOAM-1.4.1/applications/bin/linuxGccDPOpt/interFoam"

From function Pstream::init(int& argc, char**& argv)
in file Pstream.C at line 72.

FOAM aborting

[req555:18890] *** Process received signal ***
[req555:18890] Signal: Aborted (6)
[req555:18890] Signal code: (-6)
[req555:18890] [ 0] [0xffffe600]
[req555:18890] *** End of error message ***

Sender: LSF System <lsfadmin@lsfhost.localdomain>
Subject: Job 197478: </opt/hpmpi/bin/mpirun> Exited

Job </opt/hpmpi/bin/mpirun> was submitted from host <req770> by user <mou>.
Job was executed on host(s) <4*lsfhost.localdomain>, in queue <test>, as user <mou>.
</home/mou> was used as the home directory.
</work/mou/openfoam/mou-1.4.1/run/tutorials/interfoam> was used as the working directory.
Started at Fri Oct 26 10:55:30 2007
Results reported at Fri Oct 26 10:56:06 2007

Your job looked like:

# LSBATCH: User input
/opt/hpmpi/bin/mpirun -srun interFoam /work/mou/OpenFOAM/mou-1.4.1/run/tutorials/interFoam damBreakFine -parallel

Exited with exit code 134.

Resource usage summary:

CPU time : 0.22 sec.
Max Memory : 196 KB
Max Swap : 3 MB

The output (if any) is above this job summary.


I become so thankful if you review my problem.

Thank you

theory37 April 19, 2010 11:11

Any Solution to this Problem?
Hello Mou,

I know this post is ancient history, but I was wondering if you ever found a solution to this problem? I have tried installing OF 1.6 on a local cluster here, which has OF 1.5-dev installed and working properly ... all is well in serial, but I receive a very similar error when trying to run even a simple case (icoFoam cavity tutorial) in parallel.

Any help is greatly appreciated.


All times are GMT -4. The time now is 02:33.