CFD Online Discussion Forums

CFD Online Discussion Forums (
-   OpenFOAM Running, Solving & CFD (
-   -   Compilation error (

sinah September 16, 2007 19:03

Hi I am using opensuse 10.2 x
I am using opensuse 10.2 x86_64 with openfoam 1.4. I tried to compile a code to patch a parabolic inlet velocity but I couldn't.I even tried to compile turbfoam and it also failed. In 64bit mode I get a very lengthy error message and when I switched to 32bit mode and I get the following message:
Making dependency list for source file turbFoam.C
SOURCE=turbFoam.C ; g++ -m32 -Dlinux -DDP -Wall -Wno-strict-aliasing -Wextra -Wno-unused-parameter -Wold-style-cast -O3 -DNoRepository -ftemplate-depth-40 -I/home/sina/OpenFOAM/OpenFOAM-1.4/src/finiteVolume/lnInclude -I/home/sina/OpenFOAM/OpenFOAM-1.4/src/turbulenceModels -I/home/sina/OpenFOAM/OpenFOAM-1.4/src/transportModels -IlnInclude -I. -I/home/sina/OpenFOAM/OpenFOAM-1.4/src/OpenFOAM/lnInclude -fPIC -pthread -c $SOURCE -o Make/linuxGcc4DPOpt/turbFoam.o
/bin/sh: g++: command not found
make: *** [Make/linuxGcc4DPOpt/turbFoam.o] Error 127

The error messege in 64bit mode is very lengthy and I didn't bring it here(it recognizes non of the variable templates and classes) so I can't figure out what is going wrong. I appriciate any help.

msrinath80 September 16, 2007 19:10

/bin/sh: g++: command not foun
/bin/sh: g++: command not found

Suggests that wmake could not find your compiler. Your paths are messed up. Try and follow the instructions for installation as shown in the OpenCFD webpage.

sinah September 16, 2007 19:53

Hi I have installed openfoam
I have installed openfoam successfully and I'm using
it for quit some time but I'll try to reinstall it.
Have you compiled any code in 64bit mode? Does it need any special treatment?
Thanks for your reply

msrinath80 September 16, 2007 20:08

Yes, you need to set WM_64='on
Yes, you need to set WM_64='on'.

All times are GMT -4. The time now is 09:33.