CFD Online Discussion Forums

CFD Online Discussion Forums (
-   OpenFOAM Running, Solving & CFD (
-   -   RasInterFoam solver (

paka July 3, 2007 22:17

Hi everyone, For many of yo
Hi everyone,

For many of you problem might be extremely trivial.

From rasInterFoam, I copied damBreak problem to a new folder called tankTest. I just extended the domain, gamma field, and added rigid plate in a middle.
Runtime set to 40 seconds. The domain length is around 14.87m. 60cm column of water collapses and simply the flow should be quite fast. What appears, until the whole flume hits the opposing wall it takes almost whole 40 seconds.

I cannot figure out why it flows so slow - viscosity coefficients seem to be OK. The initial damBreak problem seems to work nice, video looks good, however my own example does not.

If anyone is willing to help me, here is the link, so you can download the example:

And view the movie. 25 f/sec, time step 0.04s.


paka July 9, 2007 04:01

Problem solved. Seems to be Op
Problem solved. Seems to be OpenFOAM newbie trouble.

It appears all boundary conditions areas in OpenFOAM have to be in one plane. Initially, I described a BC for plate as a one name, such as BC was:
| P L A T E |
It means four walls were defined as single BC area. Separating them into four separate areas solved the problem.

What is strange, even with "wrong" BC definitions, example was displayed correctly. Plus, gamma field had to be prescribed in coordinates without multiplication by ConvertToMeters(!). Very strange. After fixing BC, the gamma field had to be redefined with new coordinates premultiplied by ConvertToMeters.

Now, example SEEMS to work, at least in serial code. Flume takes reasonable amount of time - around 3s. But got some different problem with parallel processing, which is described here:

hjasak July 9, 2007 04:06

ConvertToMeters only applies i
ConvertToMeters only applies inside blockMeshDict - this is a mesh generation bit and nobody else in OpenFOAM can see it.


paka July 9, 2007 04:17

Sorry, maybe I didn't explain
Sorry, maybe I didn't explain it enough.

I figured out that ConvertToMeters applies only to blockMeshDict. That's why somehow it is strange.
My domain is 15 meters long. My blockMeshDict input was in [cm], so to convert to meters I had to use ConvertToMeters = 0.01.

However, the gamma field, to be properly displayed, had to be still defined in [cm]. Other way its display was a non-sense.

Then, fixing BC, to have some reasonable gamma field I had to change definitions of gamma to meters.

If there is something silly, forgive me, but I'm still new to OpenFOAM and I come from Structural field, so whole Fluid business is kind of new for me.


All times are GMT -4. The time now is 19:14.