CFD Online Discussion Forums

CFD Online Discussion Forums (
-   OpenFOAM Running, Solving & CFD (
-   -   Changes in OF 14 and compilation issues (

alberto May 3, 2007 05:49

I'm having problems to recompi
I'm having problems to recompile the libraries I used on OpenFOAM 1.3 under OpenFOAM 1.4. In other words, noone compiles!

For example, a simple BC for a parabolic velocity profile gives the error:

make: *** No rule to make target `/home/alberto/OpenFOAM/OpenFOAM-1.4/src/OpenFOAM/lnInclude/lduCoupledInterface. H', needed by `parabolicVelocityFvPatchVectorField.dep'. Stop.

Is there a reference for the main changes required to port applications to OF 1.4?

Thanks in advance,

eugene May 3, 2007 05:55

Why do you need a lduCoupledIn
Why do you need a lduCoupledInterface to make a velocity boundary condition? Anyway, I think it changed to lduInterface.

alberto May 3, 2007 07:05

Thanks Eugene, I don't need
Thanks Eugene,

I don't need lduCoupledInterface. That's just the error message I obtain when I execute "wmake libso".
I'm just using the code for the parabolic velocity profile I took from the discussion board.

However I have recompiled OF from sources and it seems something went wrong and was causing the problem.

I reinstalled the binaries and now it works.


gschaider May 3, 2007 07:10

Hi Alberto! Have you done a
Hi Alberto!

Have you done a wclean before wmake? The old *.dep files won't work with 1.4 (at least that solved that problem for me, when I was porting stuff to 1.4.


alberto May 3, 2007 07:18

Yes I did it Bernhard, now the
Yes I did it Bernhard, now the problems is with the line:

const vectorField::subField c = patch().Cf();

which gives:

parabolicVelocityFvPatchVectorField.C:122: error: conversion from 'const Foam::Field<foam::vector<double> >' to non-scalar type 'Foam::SubField<foam::vector<double> >' requested

hjasak May 3, 2007 07:22

Try const vectorField& c =

const vectorField& c = patch().Cf();


alberto May 3, 2007 07:33

Thanks Hrvoje! I wonder why
Thanks Hrvoje!

I wonder why these small changes were done however. I'm porting two apps and some library to 1.4, but it's taking too much time.

I'm considering to stick with 1.3 actually. Was it really necessary to break backward compatibility?


aurelia May 4, 2007 11:01

Hello! I get errors when I co
I get errors when I compile IcolagrangianFoam with OpenFoam 1.4.

/home/aurelia/OpenFOAM/OpenFOAM-1.4/src/finiteVolume/lnInclude/volPointInterpola tion.H: In constructor 'Foam::IncompressibleCloud::IncompressibleCloud(co nst Foam::volPointInterpolation&, const Foam::volVectorField&)':
/home/aurelia/OpenFOAM/OpenFOAM-1.4/src/finiteVolume/lnInclude/volPointInterpola tion.H:70: error: 'Foam::volPointInterpolation::volPointInterpolatio n(const Foam::volPointInterpolation&)' is private
IncompressibleCloud.C:68: error: within this context
IncompressibleCloud.C: In member function 'void Foam::IncompressibleCloud::track()':
IncompressibleCloud.C:154: error: 'track' is not a member of 'Foam::Cloud<foam::hardballparticle>'
make: *** [Make/linuxGcc4DPOpt/IncompressibleCloud.o] Error 1

I changed the name of the function called by track() ( Cloud<hardballparticle>::move(*this); ) in IncompressibleCloud.C as it was done in the new Cloud.C. This solves the last error.

But I don't know how to correct the error due the fact that the class volPointInterpolation has been rewritten in version 1.4 and cannot be used anymore in
IncompressibleCloud::IncompressibleCloud(const volPointInterpolation& vpi,const volVectorField& U)

I don't understand either the message of error for the line 68 which is interpolationSchemes_(cloudProperties_.subDict("in terpolationSchemes"))

Thanks if you can help me...

gschaider May 7, 2007 11:29

Hi Aurelia! Making the synt
Hi Aurelia!

Making the syntax errors go away won't produce a working solver because there is a very subtle difference in the way the subtimesteps are calculated between 1.3 and 1.4. I have a version lying around on my disk that is sort-of-working wich I will push to the Wiki as soon as I am confident that it is really working. If you need it urgently, drop me a mail and I'll send the intermedioate version to you


ed_teller May 10, 2007 10:50

How can I compile a new solver
How can I compile a new solver under OpenFOAM 1.4...? what is the directory structure of my solver, and what should be the requested files, #includes,... etc?

alberto May 10, 2007 14:03

It's the same of 1.3. The stru
It's the same of 1.3. The structure of the solver is in the manual.

There were some changes in the syntax mainly.


ed_teller May 11, 2007 12:17

Thanks Alberto, but my main di
Thanks Alberto, but my main difficulty is on how to couple several solvers in a multiphysics setup: I need Compressible MHD, Radiation Hydrodynamics, Phase Transition, and Multigroup (species) Diffusion,...

I know the field equations of the several phenomena.. but i still cannot grasp the numerics of building a single not seggregated solver for the problem...

Simulating a shock implosion in a MHD plasma under a Z-Pinch, to acess the occurence (or not) of Richtmeyer Meshkov instability...

dmoroian May 11, 2007 15:09

An example of multiphysics cou
An example of multiphysics coupled solver is icoFsiFoam. Try to start from there.
There are also examples of segregated solvers (search the wiki for "conjugate heat transfer" or this forum).


ed_teller May 13, 2007 15:21

Thx Dragos... Besides the f
Thx Dragos...

Besides the fact that the stuff I am trying to simulate is a rather complex one, I am a newbie in OpenFOAM... but I will see the wiki and the icoFsiFoam to see if I can grasp multiphysics solver methodology... Thx a Lot..


All times are GMT -4. The time now is 13:48.