CFD Online Discussion Forums

CFD Online Discussion Forums (
-   OpenFOAM Running, Solving & CFD (
-   -   Running icoDyMFoam from FoamX (

jdkummer September 12, 2006 09:30

I am a new user of OpenFOAM, a
I am a new user of OpenFOAM, and am so far extremely excited by its capabilities. I have a coupe of questions if anyone can help.

I added the icoDyMFoam directory to the control file so that I could see it in FoamX. When I executed the movingCone tutorial case from the command line via:

blockMesh . movingCone
icoDyMFoam . movingCone

it seems to have run fine.

However, when I double-click on the movingCone case in FoamX I get the error "getApplication::Invalid application class name 'icoFoamAutoMotion'."

I do not see anything called icoFoamAutoMotion anywhere, but still the case ran correctly from the command line, so I am confused?

Also, how do I add the ability to start a new icoDyMFoam case from within FoamX? It is currently not available on the list when I click "create case."

One more thing: the documentation states that icoDyMFoam is for laminar flow. I wish to simulate a rotating fan with turbulent flow. Is it possible to add in the ability to solve for turbulence within this application? Or is there another application better suited for sliding meshes.



hjasak September 12, 2006 12:32

Edit system/controlDict in you
Edit system/controlDict in your case and replace:

application icoFoamAutoMotion;


application icoDyMFoam;

This will solve your immediate problem. I would not be suprised if you come across more trouble: in this case, just switch to running things from command line.



jdkummer September 12, 2006 12:42

I tried this, and it will stil
I tried this, and it will still run from command line, but not through FoamX. I get the same error, but now it says:

"The Open Case operation failed due to
getApplication::Invalid application class name 'icoDyMFoam'.

Is there a difference between icoautomeshmotion and icodymfoam, since I still cannot find the former in any of the directories?

Also, I am still unable to figure out how to add this application into FoamX so that when I select "create case" it is available in the list. This may be related to why it fails to open in FoamX.


mattijs September 13, 2006 04:31


This is a bit out of date now though. Use $FOAMX_CONFIG everywhere instead.

All times are GMT -4. The time now is 20:06.