CFD Online Discussion Forums

CFD Online Discussion Forums (
-   OpenFOAM Running, Solving & CFD (
-   -   OpenFoam parallel crashes at random (

prapanj April 17, 2009 06:17

OpenFoam parallel crashes at random
I have OpenFoam and openMPI installed on a 8 core cluster. I had once case run successfully in parallel before.

On the next case (buoyantSimpleFoam), the run crashes at random. Which means, when I rerun from the latest time, everything works fine and the run proceeds beyond the previous crash time. I tried running in series, and there is absolutely no problem

The following is part of the log that I think might help some of you figure out what may be wrong:
[0] Maximum number of iterations exceeded#0 Foam::error::printStack(Foam::Ostream&) in "/home/rwdi-india/OpenFOAM/OpenFOAM-1.5/lib/linuxGccDPOpt/"
#1 Foam::error::abort() in "/home/rwdi-india/OpenFOAM/OpenFOAM-1.5/lib/linuxGccDPOpt/"
#2 Foam::hThermo<Foam::pureMixture<Foam::constTranspo rt<Foam::specieThermo<Foam::hConstThermo<Foam::per fectGas> > > > >::calculate() in "/home/rwdi-india/OpenFOAM/OpenFOAM-1.5/lib/linuxGccDPOpt/"
#3 Foam::hThermo<Foam::pureMixture<Foam::constTranspo rt<Foam::specieThermo<Foam::hConstThermo<Foam::per fectGas> > > > >::hThermo(Foam::fvMesh const&) in "/home/rwdi-india/OpenFOAM/OpenFOAM-1.5/lib/linuxGccDPOpt/"
#4 Foam::basicThermo::addfvMeshConstructorToTable<Foa m::hThermo<Foam::pureMixture<Foam::constTransport< Foam::specieThermo<Foam::hConstThermo<Foam::perfec tGas> > > > > >::New(Foam::fvMesh const&) in "/home/rwdi-india/OpenFOAM/OpenFOAM-1.5/lib/linuxGccDPOpt/"
#5 Foam::basicThermo::New(Foam::fvMesh const&) in "/home/rwdi-india/OpenFOAM/OpenFOAM-1.5/lib/linuxGccDPOpt/"
#6 main in "/home/rwdi-india/OpenFOAM/OpenFOAM-1.5/applications/bin/linuxGccDPOpt/buoyantSimpleFoam"
#7 __libc_start_main in "/lib/tls/i686/cmov/"
#8 Foam::regIOobject::readIfModified() in "/home/rwdi-india/OpenFOAM/OpenFOAM-1.5/applications/bin/linuxGccDPOpt/buoyantSimpleFoam"

It reduced the tolerance on 'h' considerably. But that wouldn't help either. What might be going wrong?
Please keep in mind that there is absolutely no problem in serial run.

Thank you

oskar April 17, 2009 07:47

I had a similar instability problem.
Getting a openFoam 1.5.x update and compiling seemed to help somewhat.
I also changed to mpi 1.3.0 (mostly due to nVidia driver incompatibility with 1.2.8 disturbing paraView)

But the biggest problem what a 9950 phenom computer being unstable. Would crash at random places when compiling, often crashing opensuse at the same time. Upgrading the bios solved that and now I have no more instability issues. (not sure if it was the TLB bug or tweaked memory usage, not very specific bios documentation)

Don't know how much of this is applicable to your problem, but this worked for me.

prapanj April 22, 2009 07:34

upgraded but...
Hi Oskar,

Thank you for your reply. I was wondering why no one else got the same bug. I have upgraded to OpenFoam-1.5.x. And I still have the bug. And now it shows a sigFpeHandler(int) error. this is different from what was happening earlier. The funny thing is, it is still running fine in serial. I am using buoyantSimpleFoam by the way with compressible turbulence model komegaSST.

I have a question. How do I use git pull to upgrade the 1.5.x source code? coz when I do git pull http:blahblah while inside the OpenFOAM-1.5.x directory, it doesn't work.

I also found my openMPI version is 1.2.6. I don't know how to upgrade to 1.3 as I don't see it in the repository. I am stuck here. Have I actually found a bug?
Any idea?

l_r_mcglashan April 22, 2009 07:49

See this thread. Set floatTransfer to zero in etc/controlDict.

All times are GMT -4. The time now is 19:59.