CFD Online Discussion Forums

CFD Online Discussion Forums (
-   OpenFOAM Running, Solving & CFD (
-   -   MPI error on Ubuntu 9.04 (

denner June 11, 2009 05:37

MPI error on Ubuntu 9.04
Hey OpenFOAM professionals,

a colleague of me runs OpenFOAM on a Ubuntu 9.04 VirtualMachine. If he likes to run his case parallel on local CPUs he get the following error message:

[0] Wrong number of arguments, expected 0 found 2
FOAM parallel run exiting
[VMUbuntu:04166] MPI_ABORT invoked on rank 0 in communicator MPI_COMM_WORLD with errorcode 1
mpirun noticed that job rank 1 with PID 4167 on node VMUbuntu exited on signal 15 (Terminated).

Does anybody know what's wrong?

Kind regards,

denner June 11, 2009 07:56

Problem solved!
It has been a user error ;)

Cheers, Fabian

sega June 11, 2009 08:46

Which virtual machine have you been using?

I tried VirtualBox from Sun, but this software is not able to address multiple CPUs from the host system so far.

denner June 13, 2009 13:38

Hey sega,

you are right. He can't run in parallel.
Well no error occurs during decompose or when the solver is called. But he simply "distributes" the parts to the same CPU.

Cheers, Fabian

All times are GMT -4. The time now is 21:28.