CFD Online Discussion Forums

CFD Online Discussion Forums (
-   OpenFOAM Running, Solving & CFD (
-   -   newbie problem with cavity tutorial (

miki August 8, 2009 13:34

newbie problem with cavity tutorial
Yesterday I installed (I think correctly) OpenFoam and I started with the cavity tutorial to learn how it works. It seems very very interesting.

But I've a problem... Following the tutorial, after typing "blockMesh" it's suggested to open paraFoam and view the mesh.
But I cannot see nothing!
It's said to check some boxes in the Region Status panel. I think now it's called "Mesh Parts" or I'm wrong?
Well, but even checking every boxes and clicking on Apply button, nothing appears.

Even zooming in or out, changing colors... nothing!

The only things that paraview shows are a lot of red small prints overlaying. They are obtained checking "Show patch names": it'a good sign. Paraview is alive.

Maybe the problem is a very simple thing.
I cannot see any cavity mesh in Paraview's window.
I want to unblock myself from this problem to learn to use OpenFoam

What can I do to see the same mesh that is in the tutorial?

Thanks in advance.

Ahmed August 8, 2009 13:47

1- Did you select the zones to display?
2- Did you change/select the background color and the foreground color

Carefully read the tutorial
Good Luck

Wolle December 10, 2009 05:00

Hi all,

it seems I've got the same problem, as miki has. Miki, can you confirm the appearance of ParaView as shown in my screenshots?

For the record: System is a brand new Xubuntu 9.04-32, OpenFOAM installed completely from the binary packages.

When I execute blockMesh and paraFoam, the following window appears. Just to show you, that there simply ISN'T something called "Region Status" (though I've seen it on other screenshots).

Afterwards, changing the "View settings" and what it looks like:

Next I changed the general settings (colors are not my taste, just to figure out)...

As you can see, no changes. Do I chose the whole "Mesh Parts" thing (as I suspect a renaming of the "Region Status" thing), included sets and zones and the patch names:
(By the way: In the tutorials, sometimes they refer to "Vol Field Status", which has obviously also been renamed to "Volume Fields"...)

Still, nothing to see, but the labels (when I chose them seperately, I can read them. They've got the names listed in the Mesh Parts list). So I go on to the Display settings and chose "Wireframe" and "Color By > Solid Color". Sadly, no "Set Solid Color" button (as I've seen in different screenshots) appears.

So from here on, I'm stuck and I think it's the same problem, miki has had encountered. I didn't make any other changes, started with a clean, blank and fresh Linux, installed openFOAM from the binaries and copied the tutorial files. Next steps are all described here.

What am I doing wrong?


BTW: Clicking "Zoom to data", adjusting/reseting the view etc. doesn't produce any other result. Just for the record: ParaView seems to read the case data though:

Bjw December 10, 2009 06:14

ParaFoam may cause problems on some machines. You can try converting your data using


and then open the VTK files with paraview.

Wolle December 10, 2009 09:08

Hi Björn,

thanks for your help. foamToVTK indeed produces a directory named "VTK". When I launch paraview and open VTK/cavity_0.vtk, I can see the mesh.

Unfortunately, the other options at the left (selecting fields or meshes) are gone then.

I guess, I have to load both, old OpenFOAM files and VTK files? How do I use your hint for fluent working?

And another approach: Why is it, that ParaView doesn't like the native OpenFOAM files? Can you give a hint concerning the cause of this effect? Is that maybe related to my installation from binaries and could be solved by compiling all from sources?


Bjw December 10, 2009 09:44

Hi Wolle,

foamToVTK produces VTK files for the internal mesh and one for every patch. You should see an extra directory for every patch in the VTK folder. So you can still choose what you want to import; it's just not as comfortable as with paraFoam.

Unfortunately, I don't know why paraFoam is not working on some machines. In our pool, we see that it's working on machines that run openSUSE 11, but it's not working on SUSE 10. We see this behavior with a self-compiled 1.5.x as well as with a pre-compiled 1.6.

Greetings, Björn

Wolle December 11, 2009 04:10

Hi all!

I think I found the reason for that behaviour of paraFoam and (what is best) I think I found a solution for this problem, too.

This is, where I found it:

So obviously, you simply have to add a line:

export LC_ALL=C
in the beginning of the paraFoam script in order to suspend your local LOCALES settings, that might cause the conflict within paraFoam.

What I don't know, is whether this is vaild for German users only (as Björn and I seem to be German) or whether it is also a solution for mikis (who doesn't seem to be German, though not English as well) problem... needs further confirmation!


greenleader September 2, 2012 10:09

I am having the same problem - mesh won't display. I am using 32-bit Ubuntu 12.04.1 and ParaView 3.12.0. I am a new user of linux and parafoam (1 week!) so I don;t really have any clue where to look - any pointers appreciated. I've gone through this post and tried all the suggestions, including VTK and searched for other threads, but no joy.

notavishal September 2, 2012 15:22

pls help me out...

Originally Posted by Ahmed (Post 225696)
1- Did you select the zones to display?
2- Did you change/select the background color and the foreground color

Carefully read the tutorial
Good Luck

sir... am goin to do an cfd analysis on a moderate sized agricultural dryer..
wer in am facing diff to start with... i hav adial fans to enforce forced convection... does ansys 10 help me out???? can i proceed in tat direction.... pls help me out with ur valuable suggestion

All times are GMT -4. The time now is 17:25.