CFD Online Discussion Forums

CFD Online Discussion Forums (
-   OpenFOAM Running, Solving & CFD (
-   -   Run in parallel: bug or what? (

novyno November 10, 2009 11:34

Run in parallel: bug or what?

I've observed a strange behaviour when I tried to run in parallel a case (with multiple regions) decomposed in a "strange" way. For many reasons I have to decompose some region (with manual method) without using all processor.

For example:

if I set numberOfSubdomains = 3 (for many reasons I can't change this value) and I want to decompose my domain only using 2 CPU, it is sufficient for me that in the "manual file decomposition" appear only the number 0 and 1.

decomposePar works well and splits the domain (with only a WARNING). If I check the mesh decomposition with paraview all seems ok. But when I run

mpirun -np 3 icoFoam (for example) -parallel

the solver doesn't works...

Anyone can tell me why? Is this a bug or I can't decompose (never) a domain in this way?



All times are GMT -4. The time now is 11:54.