CFD Online Discussion Forums

CFD Online Discussion Forums (
-   OpenFOAM Running, Solving & CFD (
-   -   scalarTransportFoam out of bounds (

alexisespinosa March 12, 2010 05:02

scalarTransportFoam out of bounds
I'm using OpenFOAM1.6.x

I ran the tutorial case basic/scalarTransportFoam/pitzDaily and found that close to the upper and lower walls, near the inlet, values are above 1, while I suppose that the scalar should be bounded between 0 and 1. (I'm obtaining values around T=1.007)

I was curious about that and I set diffusivity to 0.0 in the transport properties and ran again. Now I get values above T=1.5 and some very small negative values. This wrong values again are concentrated close to the upper and lower walls, specially near the inlet, but in the upper boundary it extends along the whole domain for the first row of cells close to the wall.

I supposed that this was a convection scheme problem and that it would be fixed using upwind scheme for convection. So I changed the convection scheme to upwind:

default none;
div(phi,T) Gauss upwind;

But the values are still out of bounds close to the wall at the inlet and close to the upper wall along the whole domain. The problem reduced a little bit, but not too much (T above 1.46)

Because this is happening close to the walls, I suppose that the zeroGradient boundary condition might not be a suitable boundary condition for a nonDiffusion case. But anyway, this problem happens even for the diffusive original example, so

What is the source of error? How can I be sure that OpenFoam will keep scalars bounded?

Thanks a lot,

danobis June 7, 2013 04:19

Hi Alexis,
I hope you're still in OF stuff, since your post has more then 3 years.
I'm studing a case similar to your and I have the same problem. Do you remeber if you solved that? And if yes, how?
Thanks Alexis!

All times are GMT -4. The time now is 17:12.