CFD Online Discussion Forums

CFD Online Discussion Forums (
-   OpenFOAM Running, Solving & CFD (
-   -   wmake errors transportModels (

T.D. September 28, 2010 06:23

wmake errors transportModels
Hi i am trying to make a new viscosityModel in transportModels
i had two directories, main($WM_PROJECT_DIR) and user($WM_PROJECT_USER_DIR).

when i copy the src folder from the main to the user directory,
i do wmake libso incompressible from transportModels folder
it makes all .o files and at last i get this error:

mkdir: cannot create directory 'linuxGccDPOpt': permission denied
/bin/sh: cannot create linuxGccDPOpt/options: Directory nonexistent
make: ***[linuxGccDPOpt/options] Error 2
/opt/openFoam171/wmake/MakeFiles:39: linuxGccDPOpt/options: No such file or directory
make: *** No rule to make target 'linuxGccDPOpt/options'. Stop.
wmake error: file 'Make/linuxGccDPOpt/objectFiles' could not be created

- i tried also from the main directory where OpenFoam is installed from /opt/OpenFoam171/src/transportModels
to do wmake libso incompressible, but i get the same error

- when i try as sudo su (administrator) i also get that wmake: command not found

Help please
where really to copy new viscosity models, how to do wmake ????

thanks a lot


FelixL September 28, 2010 06:37


you can try to temporarily change the owner of the /opt/Openfoam171-folder:

sudo chown -R username /opt/Openfoam171 (where username is the name of the current user)

Compiling should be working then.
For safety reasons it's better to change the owner back to root afterwards:

sudo chown -R root /opt/Openfoam171

Hope this helps!


T.D. September 28, 2010 08:27

Problem Solved

Thanks thanks so much, it really worked
i'm so glad, really thanks

I'll try to explain all the operation for others clearly:

Making a new viscosityModel

1-Copy the src folder from the main installed OpenFoam folder directory to your openfoam user directory.

2-copy the wanted law and change-rename it inside the /visocsityModels folder.

3-go to Make folder and add your new model directory to the existing ones

4-open console and type:

sudo chown -R username /opt/openfoam1xx

5-go back to /transportModels in the user directory of openfoam and open console and type:

wmake libso incompressible

wait till library is updated

6-change back to root by typing in a new console:

sudo chown -R root /opt/openfoam1xx

7-you can now run your applications normally with your new viscosityModel


All times are GMT -4. The time now is 20:32.