CFD Online Discussion Forums

CFD Online Discussion Forums (
-   OpenFOAM Running, Solving & CFD (
-   -   Running in parallel error (

Madeleine P. Vincent May 7, 2011 08:44

Running in parallel error
Hi OpenFoam folks,

I ran the damBreak tutorial successfully on my desktop computer in pseudo-parallel, ie, run it as parallel but on 1 CPU. This created 4 processes that were run simultaneously on 1 CPU.

However, when I tried to run the same problem on our cluster, I got errors. We use the Sun Grid Engine for queuing.

When the run begins, the new time step directories are created in each Processor sub-directory. In addition, I see via "top" that 4 processes are created on the node, but they appear to be executing on a single CPU (their % usage adds up to about 100%).

And then the run fails. I receive the following as an error log from queuing engine:

[[8641,1],0]: A high-performance Open MPI point-to-point messaging module
was unable to find any relevant network interfaces:

Module: OpenFabrics (openib)
Host: node13

Another transport will be used instead, although this may result in
lower performance.
[node13:29545] 3 more processes have sent help message help-mpi-btl-base.txt / btl:no-nics

[node13:29545] Set MCA parameter "orte_base_help_aggregate" to 0 to see all help / error messages


I am running with the command:

mpirun -np 4 interFoam -parallel

Does anyone have suggestions?

Thanks in advance,

All times are GMT -4. The time now is 10:36.