CFD Online Discussion Forums

CFD Online Discussion Forums (
-   OpenFOAM Running, Solving & CFD (
-   -   Problem with Scotch in 1.7.x? (

dancfd June 15, 2011 21:52

Problem with Scotch in 1.7.x?
Hello all,

I have just compiled OF 1.7.x without difficulty, but ran into trouble when I tried to run my first case in parallel. Upon running decomposePar with method = scotch, I received the following error:


Create time

Time = 0
Create mesh

Calculating distribution of cells
Selecting decompositionMethod scotch

You are trying to use scotch but do not have the scotchDecomp library loaded.
This message is from the dummy scotchDecomp stub library instead.

Please install scotch and make sure that is in your LD_LIBRARY_PATH.
The scotchDecomp library can then be built in $FOAM_SRC/decompositionMethods/scotchDecomp

    From function labelList scotchDecomp::decompose(const pointField&, const scalarField&)
    in file dummyScotchDecomp.C at line 193.

FOAM exiting

I am not sure how to install scotch, but I unsuccessfully tried to find the LD_LIBRARY_PATH as follows:


bash: cd: /home/dan/OpenFOAM/ThirdParty-1.7.x/platforms/linux64Gcc/paraview-3.8.0/lib/paraview-3.8:/home/dan/OpenFOAM/OpenFOAM-1.7.x/lib/linux64GccDPOpt/openmpi-1.4.1:/home/dan/OpenFOAM/ThirdParty-1.7.x/platforms/linux64Gcc/openmpi-1.4.1/lib:/home/dan/OpenFOAM/dan-1.7.0/lib/linux64GccDPOpt:/home/dan/OpenFOAM/site/1.7.x/lib/linux64GccDPOpt:/home/dan/OpenFOAM/OpenFOAM-1.7.x/lib/linux64GccDPOpt:/home/dan/OpenFOAM/OpenFOAM-1.7.x/lib/linux64GccDPOpt/dummy: No such file or directory

I just noticed that in the /lib/linux64GccDPOpt/ directory, OF 1.7.x has one less library than OF 1.7.0 - and that missing library is I ran wmake libso from the /src/decompositionMethods/scotchDecomp directory, and the missing library appeared. Now it works. I hope this monologue was of use to someone.


All times are GMT -4. The time now is 14:57.